La presente guida si basa su EvrSoft 1st Page 2000 ver. 2.0 in Inglese (non sono disponibili traduzioni, almeno per ora). Secondo le informazioni disponibili sul sito al momento della stesura di questa guida (aprile 2001), dovrebbe a breve uscire la ver. 3.0 del programma. Per informazioni consultate direttamente il sito web del produttore.
Editor WYSIWYNG e testuali

Prima di iniziare la presentazione, è d'obbligo una premessa sulla differenza tra gli editor WYSIWYNG e non.

Editor WYSIWYNG

La parola WYSIWYNG è composta dalle iniziali delle parole inglesi "What You See Is What You Get" che significa "ciò che vedi è ciò che ottieni". In parole povere ho la possibilità ad esempio di formattare una parola in grassetto o in blu e di vedere il risultato direttamente all'interno dell'editor durante la digitazione (senza bisogno di andare in modalità "anteprima" che è una simulazione del risultato sul browser). Se poi inserisco un'immagine, non vedrò il codice HTML che richiama il percorso dell'immagine ed in cui sono specificate le dimensioni, ma vedrò direttamente l'immagine e avrò anche la possibilità di ridimensionarla e di spostarla all'interno della pagina. 

Editor testuali

Un editor testuale (o non WYSIWYNG) invece, consente di vedere in tempo reale solo il codice inserito (come accade per esempio andando a vedere il codice HTML direttamente dal browser). Quindi quando formatto un testo in grassetto non vedrò altro che il testo stesso visualizzato come il resto del testo (quindi con lo stesso carattere e non in grassetto) e lo stesso testo sarà preceduto dal codice <B> e seguito dal codice </B> che indicano appunto la formattazione in grassetto. Quando inserisco un'immagine non ho la possibilità di vederla, spostarla e ridimensionarla visivamente, ma posso solo agire direttamente sul codice. Gli editor testuali però possono essere dei semplicissimi editor di testo (che consentono in definitiva solo di inserire del testo manualmente) come il famoso Blocco Note di Windows o come il più valido EditPad, oppure possono essere strutturati con delle funzioni particolari che aiutano notevolmente lo sviluppatore che lavora in un determinato linguaggio. 

1st Page 2000 si colloca proprio all'interno di quest'ultima categoria ed è disegnato appositamente per lo sviluppo di siti Internet. Un programma di questo tipo racchiude, a mio avviso, il meglio dei due tipi di editor: infatti si è sempre a contatto diretto col codice e questo permette di conoscerlo a fondo ed ottimizzarlo e soprattutto evitare i risultati spesso poco puliti dati dai programmi WYSIWYG. D'altro canto si hanno una serie di funzionalità aggiuntive tipiche di un WYSIWYNG come la possibilità di disegnare una tabella tramite una finestra di dialogo, di definire tutti i parametri per l'inserimento di un'immagine, di gestire visivamente la tavolozza dei colori, insomma di avere tutta una serie di facilitazioni che semplificano notevolmente il lavoro.

Caratteristiche di 1st Page 2000

Ma passiamo ora a vedere le caratteristiche peculiari di 1st Page 2000: 

· Ha vinto 13 awards 

· È freeware (cioè può essere usato e copiato legalmente senza pagare niente a nessuno) 

· Non crea codice proprietario (come accade con FrontPage o con ColdFusion) 

· Conosce però il codice proprietario di altri programmi (come appunto FrontPage e ColdFusion) e li sa gestire 

· Può visualizzare una lista dei comandi con possibilità di filtri per avere sempre un completo controllo sull'accessibilità 

· È utilizzabile in 3 diverse modalità: easy/expert/hardcore 

· Come se ciò non bastasse è estremamente configurabile, si possono personalizzare i tasti di scelta rapida, le barre degli strumenti (oltre che crearne di nuove), si possono far apparire e scomparire diversi pannelli aggiuntivi, si possono cambiare i colori utilizzati per identificare le varie parti del testo 

· È possibile conservare parti di codice da riutilizzare 

· Contiene diversi "parser" cioè controlli di codice con relativa visualizzazione differenziata per colore (Perl , CSS, HTML, Cold Fusion, ASP, SSI, Javascript, CGI) 

· Contiene tantissime parti di codice già pronte in vari linguaggi (JavaScript, DHTML, CGI, Perl) 

· I JavaScript considerati più utili sono disponibili direttamente tramite appositi bottoni della barra strumenti (ad esempio inserimento data/ora ultima modifica o immagini "rollover" cioè che cambiano quando ci si passa sopra il mouse) 

· È possibile visualizzare una finestra contente tutti gli oggetti JavaScript/VBScript 

· Strumenti di compressione codice (per diminuire i tempi di caricamento e rendere più difficoltosa la lettura dello stesso) 

· Supporto Flash 4/Shockwave/Java/ActiveX 

· Visione files tipo "Esplora Risorse" 

· Anteprima immagini con calcolo dimensioni e ridimensionamento 

· Apertura di documenti direttamente dal Web 

· Guida contestuale sui comandi HTML e tooltips (in inglese) 

· Controllo ortografico (anche in tempo reale) e thesaurus (entrambi solo in Inglese) 

· Lista dei caratteri speciali 

· Possibilità di visualizzare l'anteprima a diverse risoluzioni senza intervenire sulla risoluzione del sistema operativo 

· Possibilità di creare dei Templates o di utilizzarne di già pronti 

· Include 1st Transfer, un programma FTP richiamabile da 1st Page o anche esternamente 

· Integra i Preferiti di Explorer e quelli di Netscape 

· 4 diversi browser richiamabili per l'anteprima 

· Conversione testo->HTML, HTML->HTML+CSS e HTML->XML 

· Include tante finestre di dialogo che permettono di impostare il codice in maniera visuale; all'interno di tali finestre è sempre specificato se una determinata opzione è riconosciuta solo da Explorer o solo da Netscape 

· Gestione Progetti con indicazione di "In corso"/"Completato" e possibilità di associazione di diverse icone 

Appena installato il programma, ci si trova ad osservare all'interno del menu Avvio->Programmi di Windows, una nuova cartella e fin qui nulla di strano. Ma all'interno di tale cartella, oltre i soliti link aggiuntivi relativi a guide e testi introduttivi, abbiamo ben 4 link relativi al programma: 

· Easy 

· Normal 

· Expert 

· Hardcore 

Abbiamo infine un link "Javascript Rollover Module" che consente di creare direttamente il codice relativo alle cosiddette immagini con effetto rollover, cioè che variano appena ci si posiziona sopra con il mouse. Eseguendo tale operazione senza aver aperto 1st Page, il codice viene creato e salvato all'interno degli appunti di Windows. 

Ma andiamo subito ad esaminare come mai esistono 4 link per avviare un unico programma. A seconda del link che si sceglie, cambia completamente la barra degli strumenti visualizzata in alto. È quasi come avere tre programmi in uno. Ma come 3? non erano 4? La modalità "Normal" è una modalità particolare che riprende le precedenti e che vedremo per ultima. Per quanto riguarda le altre, premetto che ciò che cambia è solo la barra degli strumenti, perciò i menu e tutte le altre parti del programma restano invariate. Le barre degli strumenti invece, non subiscono una semplice ritoccata, ma sono strutturate in 3 maniere completamente diverse. Ma il modo migliore per capirne la differenza è vederle. Perciò ve le presento: 

Easy (Facile)


Expert (Esperto)
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In modalità Expert, come potete vedere dall'immagine qui sopra, a destra c'è la Tooltab, cioè un insieme di barre strumenti richiamabili tramite la linquetta che ne identifica il titolo. Sulla sinistra invece, ci sono 4 barre strumenti "solitarie"; quando farò riferimento a queste, ne indicherò comunque il nome, che potete vedere nell'immagine qui sotto.
È la modalità che preferisco in quanto mette a disposizione tutti gli strumenti in maniera molto pratica. Inoltre è l'unica modalità che consente la personalizzazione della Barra Strumenti. 
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Hardcore (come si traduce? Diciamo Espertissimo)

[image: image3.jpg]BTy L N [ L L T L R




In questo caso la barra degli strumenti si presenta con una serie di tasti formati da un disegno ed una scritta i quali aprono dei menu contenenti una lista di comandi accompagnati nella maggior parte dei casi da una breve descrizione. Questa è la modalità preferita dagli amanti degli editor testuali puri. È inoltre un ottimo metodo per imparare i comandi HTML e per memorizzarli meglio. Purtroppo anche in questo caso mancano le barre strumenti con i comandi come "Salva" o "Annulla" che dovranno essere richiamati dal menu o tramite tasti di scelta rapida. 

Normal (normale)

La modalità Normal consente di visualizzare da zero a tre barre strumenti in un'unica visualizzazione. Per fare questo bisogna trovarsi innanzitutto in modalità Normal; in apparenza rimane tutto uguale ma una piccola modifica avviene. Infatti, andando sul menu [View], solo in modalità Normal sono attive le prime 3 voci e rispettivamente: 

· View Easy Bar 

· View Palette 

· View Hardcore Bar 

"View Palette" indica la barra strumenti della modalità Expert . Ognuna delle 3 voci è selezionabile/deselezionabile (con/senza segno di spunta). In questa maniera è possibile crearsi il proprio ambiente personalizzato sfruttando la potenza di qualunque barra strumenti. 

Convenzione per i colori

Vorrei indicare la maniera in cui verranno presentati i capitoli successivi: non ci saranno 3 corsi separati per ogni modalità di utilizzo. Ci sarà invece una spiegazione basata sui risultati che si intendono ottenere (ad esempio: inserimento di un'immagine, formattazione di HEAD, ecc.) e all'interno del capitolo verranno analizzati i metodi che consentono di ottenere tale risultato nelle varie modalità. In questa maniera ognuno potrà valutare quale metodo trova più efficiente e più appropriato al proprio modo di operare. Per semplificare il lavoro di lettura, utilizzerò diversi colori per indicare la spiegazione di un comando all'interno di una particolare modalità. I colori utilizzati sono gli stessi che caratterizzano le icone di avvio (a parte il giallo che sarebbe risultato illegibile ;-). In particolare abbiamo: 

· Easy: verde 

· Expert: rosso 

· Hardcore: arancio 

I comandi del [menu] verranno invece inseriti tra parentesi quadre e quelli del menu contestuale (cioè quello che appare premendo il tasto destro del mouse) saranno in rosa in modo da facilitarne la consultazione. 

Passare da una modalità all'altra

In questa lezione abbiamo visto in linea generale le differenze fra le 3 modalità di utilizzo del programma. A prescindere dalla modalità prescelta, è possibile comunque effettuare tutta una serie di ulteriori personalizzazioni nell'utilizzo. Queste personalizzazioni ulteriori verranno approfondite nei capitoli successivi.
Per ora mi preme sottolineare innanzitutto che è possibile passare da una modalità all'altra anche dall'interno del programma, tramite il menu [Options->Switch to .... mode], oppure dalla barra Expert: View->Mode Switch
A prescindere dalla modalità di avvio prescelta, al primo avvio appare lo "Start Manager"; in basso abbiamo 2 possibilità di scelta: "Show this screen everytime 1st Page starts" che, se abilitato, fa riapparire lo start manager ad ogni avvio del programma e "Create a new document on startup" che crea un nuovo documento ad ogni avvio del programma. La modifica di queste opzioni ha validità globale, cioè se decido avviando ad esempio la modalità Hardcore, di non visualizzare lo startmanager all'avvio, questo non apparirà all'avvio di nessuna delle modalità. Per reimpostarlo, basta richiamare lo startmanager dal menu all'interno del programma: [File->New->From start manager] e rimettere il segno di spunta nell'opzione desiderata. Lo stesso comando è richiamabile anche dalla modalità Expert tramite il primo tasto a sinistra "Launch Start Manager". Oppure, tramite [Options->General Program Preferences->Startup]. L'opzione "Create a new document on startup" crea un documento in base al template predefinito che può essere personalizzato.

Le varie possibilità offerte dallo Start Manager

Passiamo ora ad esaminare il contenuto vero e proprio dello Start Manager. Sul lato destro sono presenti diversi tasti che servono per richiamare diverse funzioni visualizzate poi nella parte larga della schermata. Inizialmente si parte con la schermata "Startup" che non è altro che una breve descrizione delle altre opzioni. Andando invece su "New Documents" è possibile creare un nuovo documento basato su dei Templates predefiniti tra cui: 

· "Blank Document" crea un documento completamente vuoto (utile ad esempio per creare un file di testo o per inserire solo ciò che si desidera). 

· Con "HTML Document" si crea invece un documento HTML tramite un template predefinito; questo documento è caratterizzato dalla presenza dei principali tag all'interno della sezione HEAD. N.B.: Questo template non è personalizzabile. 

Seguono alcuni altri template facilmente riconoscibili dal nome. Il terzo tasto "User Templates" visualizza inizialmente una schermata vuota, che potrà essere personalizzata tramite la creazione di propri templates personali. 

I templates personali

Per aggiungere un nuovo template a questa sezione è necessario creare o aprire il documento che si vuole salvare come template, scegliere dal menu [File->Save as template] e indicare il nome da assegnare. Dopo aver fatto questa operazione, il documento appena salvato sarà visibile all'interno dello startmanager come template dell'utente. I templates vengono salvati in una sottodirectory di 1st Page chiamata Templates->Others. Da lì è possibile richiamarli per effettuare delle modifiche. Fate attenzione in caso di modifica a non eliminare una scritta aggiuntiva presente a fine file che contiene la posizione del cursore. L'eliminazione di un template è effettuabile invece anche dallo stesso Startup tramite menu contestuale (tasto destro sul nome del template). Gli altri tasti servono per avviare degli aiuti sull'utilizzo del programma.
Attenzione: se salvando un Template, indico il nome di un template personale già presente, esso verrà sostituito senza preavviso. 

Come cambiare il "Default Template"

Tramite il menu [Options->General Program Preferences->Scheda General]: in basso è possibile indicare il percorso del template che si desidera utilizzare come Default.
Il Default Template viene richiamato nei seguenti casi: 

· [File->New web document] 

· [File->New->Default template] 

· Indicando nello Start Manager l'opzione di creazione nuovo documento all'avvio 

Un nuovo documento, come già avrete capito, può essere creato in vari modi che per semplicità elenco tutti qui di seguito: 

· Tramite impostazione di creazione nuovo documento all'avvio 

· Tramite tasto Creates a new web document in modalità Esperto; corrispondente del menu: [File->New web document] 

· Tramite Start Manager scegliendo tra i templates predefiniti e quelli personalizzati 

· Tramite altre opzioni del menu [File->New] che non sto ad elencare perché richiamano alcuni dei comandi presenti nello start manager 

· Tramite menu contestuale. Se è aperto almeno un file, noterete in basso una o più linguette con i nomi dei files aperti. Premendo con il tasto destro del mouse sarà possibile richiamare la voce New. 

Partendo da un documento completamente vuoto, è possibile inserire velocemente la struttura di base di un documento web anche tramite un tasto presente nella barra strumenti expert: Standard->Fast Start; tale opzione inserisce nel documento lo stesso contenuto che si avrebbe partendo dal template "HTML Document". 

Come impostare la creazione/non creazione di un nuovo documento all'avvio

Tramite il menu: [Options->General program preferences->Startup->Create a new (untitled) document on startup].
1st Page viene fornito senza una guida (è anche per questo che ne ho creato una). Andando sulla linguetta "Reference" però, è possibile seguire una panoramica in inglese sulle caratteristiche del programma e trovare diverse guide dettagliate (sempre in inglese) create dalla Web Design Group (WDG) e riguardanti HTML 4, novità di HTML 4 rispetto alla versione precedente e CSS. Inoltre una lista piuttosto estesa di FAQ (domande frequenti) e cenni su SSI più qualche altro documento.
Vorrei però evidenziare che basterà premere F1 mentre si è all'interno di un qualunque tag HTML per avere immediatamente accesso alla guida relativa a quel tag. Per quanto riguarda i wizard poi, sono forniti di fumetti a comparsa su ogni campo.
Infine, sulla Sidebar, la prima opzione sulla destra, presenta una lista dei tag HTML 4.0 affiancati da una descrizione rapida (ad esempio il tag B viene indicato come "Bold Text"); inoltre basta premere sul tag stesso per vedere la guida completa relativa ad esso. 

Consultazione guida e barra strumenti
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	Durante la consultazione delle guide, sul lato sinistro dello schermo, appare la barra strumenti che vedete qui a fianco.
Essa consente di andare avanti ed indietro nella consultazione (BACK e FORWARD), di raggiungere immediatamente la lista delle guide (SHOW REFERENCE CONTENTS), di vedere una lista di tutti i comandi HTML ordinata alfabeticamente o per categorie (SHOW ELEMENTS LIST IN ...).
Infine possiamo selezionare una parte della guida da copiare negli appunti (ad esempio un esempio di codice) ma, considerando che i normali strumenti di copia negli appunti non funzionano durante la visualizzazione della guida, tale operazione va fatta ancora da questa barra strumenti. Infine abbiamo il comando di stampa e quello che consente di visualizzare la guida all'interno di Internet Explorer. 


Può sembrare superfluo un capitolo dedicato all'apertura dei documenti, so che tutti voi siete in grado di aprire un documento senza bisogno di una guida, ma il presente capitolo vuole solo mettere in evidenza alcuni pregi e difetti di 1st Page riguardanti questo comando.
Oltre il classico comando presente sia sul menu che sulla barra Expert, vorrei farvi notare quanto segue: 

Lista files recenti
[(File->Reopen)]; visualizza una lista degli ultimi 20!!! files aperti. 

Apertura files Internet
Possibilità di richiedere direttamente l'apertura di una pagina tramite url internet ([File->Open from the web]); utile per studiare su siti altrui :) 

menu contestuale in 1st Page
Se avete già almeno un file aperto, noterete in basso una o più linguette con i nomi dei files aperti. Premendo sulla linguetta col tasto destro del mouse, vengono visualizzate diverse voci tra cui Open. 
Il menu contestuale, se aperto mentre il mouse è posizionato sul nome di un file in modalità Edit, presenta una voce apposita: Open File at cursor che apre il file sul cui nome si è posizionati. 

menu contestuale in Windows
Dopo aver installato il programma, viene aggiunta una voce al menu contestuale di Windows (quello richiamabile con tasto destro del mouse da Esplora Risorse). La nuova voce, attiva per i tipi di files riconosciuti da 1st Page è "Edit with 1st Page 2000" e consente naturalmente di aprire direttamente il programma con quel documento. 

Side Bar contenente il Local Tab ed il Project Manager

La side bar è un pannello che può essere visualizzato a sinistra o a destra e che a sua volta può visualizzare diverse schermate utili (per ora ne vediamo solo due). Se non sapete di cosa sto parlando probabilmente non l'avete abilitato. È attivabile/disattivabile tramite menu: [View->Side Panel] o con tasto F9; se l'avete attivato e continuate a non vederlo, noterete almeno la presenza di una barra verticale con dei puntini e due frecce all'estrema sinistra dello schermo (o all'estrema destra, ma prima della tavolozza colori). In tal caso basta trascinare la barra verso l'interno per ridimensionare lo spazio da dedicare al fatidico Side Panel. Per spostarlo da destra a sinistra e viceversa: [View->Sidebar options->Docking].
Nell'immagine qui sotto potete notare le varie opzioni di visualizzazione della Side Bar (o side panel)[image: image5.jpg]Goto [CADATNGuGalstPage o]
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Local tab (File Explorer)
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	È la prima visualizzazione che si ottiene all'attivazione del side panel ed è richiamabile premendo sul computerino (in basso). Come avrete notato, contiene in alto l'albero delle directory, o meglio tutte le Risorse del computer (è anche possibile ad esempio aprire il Pannello di Controllo) ed in basso la lista di files o di risorse della directory attiva. Le 2 finestre sono ridimensionabili a piacere. La finestra in basso ha un menu contestuale con diverse opzioni tra le quali segnalo: Edit che apre la pagina all'interno dell'editor, Insert as link che inserisce nel punto di inserimento un link a quel file, View che apre la pagina in anteprima in una piccola finestra esterna, Filter che consente di filtrare la visualizzazione dei files, il comodissimo Explore from here che apre una finestra di Esplora Risorse a partire dalla directory selezionata, ed infine la possibilità di creare una propria lista di percorsi preferiti richiamabili rapidamente. Non mi dilungo in ulteriori spiegazioni perché sono opzioni abbastanza semplici, ma utili. Infine, sotto la seconda finestra (quella dei files), può essere visualizzata o meno (Options->Quick path bar) una barra che consente di inserire direttamente un percorso. 


Directory di apertura del File Explorer
Può essere impostata in maniera fissa o sull'ultima visualizzata. Tale impostazione va effettuata su: [Options->General Program Preferences->Startup->Side File Explorer]. 

Project Manager
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	Il Project Manager (secondo tasto da destra, quello con un mondo ed un foglio) consente di elencare una serie di documenti, anche appartenenti a cartelle diverse, all'interno di un unico progetto. Un file può appartenere anche a diversi progetti. Inoltre (tramite menu contestuale) è possibile gestire i progetti indicando per ogni file lo stato di avanzamento (completato/in progresso) e assegnare diverse icone ad alcuni files (utili le icone numerate per indicare uno stato di avanzamento da 1 a 9). Utili anche in questo caso, la possibilità di inserire uno o più files come link, o di aprire uno o più documenti o di aggiornare la data/ora. Per vedere tutti i dettagli dei files ingrandite il side panel o scorrete orizzontalmente la lista. Il menu di gestione dei progetti (crea, apri, salva, chiudi) è accessibile tramite il tasto in alto "Project Manager".
Attenzione: Selezionando "Delete File(s)" dal menu contestuale, si ha l'eliminazione dal progetto ma non l'eliminazione fisica del file dal supporto di memorizzazione. 


Chiusura files

Visto che ci siamo, accenno alla possibilità di chiudere i files sempre dal menu contestuale (in basso) e tramite il tastino rosso a forma di X presente appena sotto la linguetta "Edit". Su tale barra sono inoltre presenti molte altre funzioni che vedremo in seguito. Molto utile infine la voce del menu [File->Close all] che consente di chiudere tutti i documenti aperti. 

Salvataggio files

Anche questo è possibile dal menu normale e da quello contestuale, oltre che tramite la barra Expert. Vorrei però segnalare due opzioni aggiuntive: [File->Save All] che consente di salvare in un'unica operazione tutti i files aperti e [File->Save as template] che consente di creare dei modelli riutilizzabili e richiamabili tramite lo Start Manager. Infine [File->Save to FTP] non sembra che sia attivo (peccato).
Un'altra opzione presente e non funzionante consiste nella possibilità di impostare tramite [Options->General Program Preferences->General->Documents->Default file extension when saving] l'estensione dei file durante il salvataggio (che viene aggiunta in automatico se non ne viene specificata una dall'utente), ma in realtà l'estensione predefinita rimane sempre HTML. 

Difetti

Un piccolo difetto (secondo me) è il fatto che quando non è aperto nessun documento, non è possibile né utilizzare il Local Tab, né aprire un progetto. Spero che la cosa venga modificata in una prossima versione. Per il momento il problema può essere evitato attivando la creazione automatica di un nuovo documento all'avvio.

Si tratta di un'impostazione semplicissima e fondamentale che è importante vedere subito.

Se sul menu [Options->Grouped Undo] è presente un segno di spunta, sono consentite più azioni di annullamento con uno storico piuttosto lungo. Sullo stesso menu: [Options->Undo after save], la presenza del baffetto indica che possiamo annullare un'azione anche dopo aver salvato un documento (chiaramente prima di chiudere il programma). Consiglio vivamente di lasciare il baffetto su entrambe le opzioni. 

Usare e modificare i tasti di scelta rapida

Molti tasti di scelta rapida risultano già impostati ed indicati a fianco della rispettiva voce di menu. Si possono impostare tasti di scelta rapida per qualunque impostazione tramite: [Options->Customize Keyboard Shortcuts]. 

Personalizzare le barre Expert

Premendo su una delle barre Expert col tasto destro, è possibile abilitarne/disabilitarne alcune, andando sul menu contestuale Organize è possibile cambiarne l'ordine di visualizzazione, mentre andando su Customize, è possibile cambiarne i contenuti cioè spostare, rimuovere o aggiungere alcuni strumenti e creare delle nuove barre aggiuntive. Infine, premendo sulla doppia linea verticale che sta alla sinistra di ogni barra, è possibile spostarla all'esterno della tooltab e posizionarla dove si preferisce su qualunque lato dello schermo o addirittura lasciarla fluttuante. Infine anche le 4 barre che stanno normalmente alla sinistra dello schermo possono essere spostate o inserite all'interno della Tooltab e una volta inserite lì, possono essere anche personalizzate. La stessa opzione di personalizzazione di cui vi ho parlato (anzi scritto) è raggiungibile anche dal menu [Options->Customize Toolbar].

Attenzione: Le personalizzazioni effettuate eventualmente sulla barra Expert (o Palette) restano memorizzate anche passando alla modalità Normale e viceversa. 

Modalità di lavoro personalizzata e lista comandi della SideBar

Se non vi è piaciuta nessuna delle barre strumenti presenti, esiste un'ulteriore possibilità: si può lavorare in modalità Normal disabilitando tutte le barre e eventualmente, abilitare la Sidebar e all'interno di questa andare sulla lista di visualizzazione comandi (secondo tasto da sinistra).
Da qui sarà disponibile tutta la lista dei comandi HTML e ColdFusion. Partendo dall'alto vediamo:

Un elenco a discesa da cui possiamo filtrare i tipi di comandi che vogliamo visualizzare; possiamo scegliere in base ad una delle versioni di standard HTML, o in base alla compatibilità con una specifica versione di browser Explorer o Netscape. Infine possiamo chiedere di visualizzare i comandi di ColdFusion 3 oppure le estensioni relative alla WebTv.

Se vogliamo visualizzare in contemporanea più tipi di comandi, basta premere sulla scritta "Filter Tags" e attivare o disattivare le varie opzioni.
A fianco alla scritta "Filter Tags", ci sono due bottoni che permettono di riordinare i comandi rispettivamente in ordine alfabetico o in ordine di categoria.

Se poi ingrandiamo la Side bar, possiamo notare che a fianco ad ogni comando ci sono altri dati: in particolare abbiamo la descrizione, la categoria di appartenenza, il codice iniziale e quello finale, e l'indicazione del comando completo di opzioni. Infine la prima colonna sulla sinistra, è occupata da una casella di controllo (checkbox, in pratica il quadratino che può essere segnato o meno). Considerando che la lista dei comandi è a disposizione perché possano essere inseriti agevolmente nel punto di inserimento con un doppio click del mouse, la checkbox serve ad indicare se vogliamo inserire il comando in formato base (cioè comando di apertura e di chiusura) o in formato esteso (cioè con tutte le opzioni). Una volta che ci personalizziamo tale lista dei comandi, potremo agire con la massima semplicità e inoltre con la certezza di usare i comandi corretti in base alla compatibilità che ci interessa. Quindi, se vogliamo creare un documento compatibile ad esempio con lo standard HTML 3.2, basterà impostare il filtro e non correremo il rischio di inserire comandi che siano successivi e quindi incompatibili con alcuni browser.

Ma la possibilità di personalizzazione non finisce qui: infatti, se non ci piacciono le categorie a cui sono stati assegnati alcuni comandi o se vogliamo modificarne le opzioni, basta selezionare il tag incriminato e scegliere dal menu contestuale la voce: Edit Tag che ci consentirà di modificare tutto ciò che vogliamo.

In questo capitolo vedremo alcuni comandi che vanno necessariamente inseriti all'interno del tag HEAD.
Raggiungimento veloce del tag HEAD: Barra Navigation->Goto Head Tag (omino con la testa rossa). Mediante l'utilizzo del tasto di inserimento rapido visto in precedenza, si ha una struttura di base (ma veramente molto di base). Infatti all'interno di HEAD è presente solamente il tag TITLE. Considerando che questo non è un corso di HTML, ma è finalizzato all'apprendimento dell'uso di un determinato programma, non posso spiegare ogni elemento HTML nei dettagli, vorrei però soffermarmi un attimo almeno sui tag principali di HEAD la cui importanza è spesso ignorata.

TITLE

Iniziamo con TITLE che è il più conosciuto e che permette di visualizzare un titolo qui definito, all'interno della barra del titolo del browser (programma di navigazione) utilizzato da chi visualizza la pagina. Inoltre è il titolo che appare quando si va a salvare l'indirizzo del sito sui Preferiti di Explorer o di altri programmi. Infine alcuni motori di ricerca ne tengono conto durante l'indicizzazione. 

META KEYWORDS

Può essere inserito tramite la toolbar Hardcore Document->Meta->Keywords.
Consente l'indicazione delle parole chiave che, se inserite all'interno di un motore di ricerca, danno all'interno della lista dei risultati di ricerca la nostra pagina. È quindi di fondamentale importanza sfruttare al meglio questo meta tag.
Nota:Quelli di 1st Page devono essere dei pacifisti come me, infatti inserendo il tag dalla barra, esso conterrà già 3 parole chiave pacifiste. Le vostre parole chiave andranno inserite al posto della scritta "peace, world, love".
<meta-http-equiv="keywords" content="peace, world, love"> 

META DESCRIPTION

Richiamabile tramite la toolbar Hardcore Document->Meta->Description.
Consente di indicare una breve descrizione del sito che apparirà nella lista su menzionata subito sotto il titolo del nostro sito. 

META AUTHOR

Non sto ad annoiarvi con la modalità di inserimento perché si trova tutto nella barra strumenti indicata sopra. Qui si indica il nome dell'autore della pagina. 

META GENERATOR

A differenza di altri editor, 1st Page non inserisce questo tag che gli consentirebbe di autopubblicizzarsi. Se volete potete sempre inserirlo. 
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	Inoltre chi vuole, può inserire sul proprio sito un bottoncino che indica "Powered by 1st Page". Lo trovate sul menu: [Insert->Special->Made with 1st Page 2000 logo].


META REDIRECT

Consente di reindirizzare ad un'altra pagina dopo un certo numero di secondi. Richiamandolo da 1st Page, viene anche indicato esattamente dove inserire il numero di secondi (al posto del #); la pagina a cui reindirizzare il visitatore va invece inserita al posto dell'indirizzo indicato. Può essere molto utile quando si cambia indirizzo internet, comunque non tutti i browser sono in grado di interpretare tale comando, quindi si consiglia di inserire anche una scritta con tanto di link ipertestuale che consente di effettuare il reindirizzamento anche manualmente. 

!DOCTYPE

Questo comando consente di indicare quale versione di HTML è stata utilizzata per creare la pagina. Può essere utile ai server web per interpretare il documento in maniera corretta. N.B.: Deve essere la prima riga di un documento, quindi deve precedere sia HEAD che HTML. 

ISINDEX

È un comando obsoleto, è quindi sconsigliato utilizzarlo. Viene degnamente sostituito dai vari comandi di gestione forms. 

LINK

Serve ad indicare un percorso esterno utile all'interno di una pagina. Utilizzato ad esempio per indicare un foglio di stile (CSS). 

STYLE

Al contrario di LINK, definisce un foglio di stile direttamente all'interno del documento HTML. 

Per maggiori informazioni sui meta tags, si rimanda alla guida sull'HTML presente su questo stesso sito. 

Inserire data e ora

Anche se questa impostazione non fa necessariamente parte dell'HEAD, molti hanno l'abitudine di inserire data e ora di creazione o di ultima modifica proprio all'interno dell'head (sotto forma di commento). Questa operazione può essere effettuata facilmente dal menu contestuale Date/Time Stamp; si può scegliere tra vari formati sia di sola data, di solo orario o di entrambi.

Innanzitutto anche il tab BODY è raggiungibile tramite un tasto della barra Expert: Navigation->Goto Body Tag (omino col corpo rosso).

Finestra di dialogo Body

Inoltre è possibile impostare le principali opzioni del documento tramite una comoda finestra di dialogo. Tale finestra è utilizzabile anche per effettuare modifiche (il programma seleziona automaticamente il tag BODY e riconosce e sostituisce eventuali cambiamenti). La finestra di dialogo è selezionabile nei seguenti modi:

· menu: [Format->Document Properties]
· Easy: Properties->Document Properties
· Expert: Standard->Document Body
· Hardcore: Document->Body Tag Editor
Oltre a poter impostare immagine di sfondo (Background image) e colori con tanto di anteprima, sono presenti altre due opzioni un po' meno visibili: "Watermark Fixed (Explorer only)" che permette di tenere l'immagine di sfondo fissa anche quando si scorre la pagina (come indicato funziona solo su Explorer); "Disable Scrollbars" che consente di non visualizzare le barre di scorrimento durante la visualizzazione della pagina; quest'ultima opzione è consigliata solo per finestrelle piccole; inoltre ricordate che anche se la pagina viene visualizzata per intero sul vostro pc, non è detto che accada lo stesso su qualunque altro pc (dipende dalla risoluzione, dalla grandezza del monitor, dal programma di navigazione, dal numero di barre strumenti visualizzate e dalle loro dimensioni). 

Altre opzioni sulla barra Hardcore

Sulla barra Hardcore il tasto Document contiene altre opzioni relative al BODY. Tra queste abbiamo: 

· BASE che consente di indicare il percorso di base del sito Internet. Questo consente la corretta visualizzazione delle pagine online anche partendo da una parte del sito memorizzato per la visualizzazione offline. 

· BASEFONT che indica il tipo di font di base da utilizzare per il documento. Viene utilizzato sempre se non diversamente specificato. 

Come vedremo nei capitoli successivi, vari strumenti di 1st Page richiamano, quando necessario, una tavolozza dei colori.
Se si preferisce però, si può utilizzare per la scelta dei colori, la tavolozza che appare alla destra dello schermo e attivabile mediante menu: [View->View color palette]; essa è ancora più comoda in quanto permette prima di tutto di selezionare due diversi colori (background e foreground), di copiarli comodamente nel punto di inserimento desiderato premendo sulle scritte 'FG' (foreground) e 'BG' (background); inoltre, selezionando la casella in basso 'Font', viene inserito (sempre con i 2 bottoni appena visti) l'intero codice di formattazione del testo. Se poi la tavolozza non è sufficiente perché troppo piccola, basta premere sul colore attivo e viene richiamata una tavolozza colori più completa. Peccato che definendo un colore personalizzato dalla tavolozza del Font tag editor, lo stesso colore non venga reso disponibile all'interno dell'altra tavolozza.

Tavolozza Color Saver per Internet

Infine, sulla barra Standard Quick Tools->Color Picker (in alto a sinistra), è disponibile una tavolozza con soli 216 colori; è consigliabile l'utilizzo di quest'ultima perché compatibile universalmente. Premendo il tasto MORE, si ha una tavolozza con i colori supportati da Windows (351). In alto a sinistra abbiamo in anteprima il colore scelto ed il relativo codice.

A capo automatico

Il testo può essere inserito come in qualunque editor di testi o di documenti e fin qui nulla di nuovo. Per orientarsi meglio durante l'inserimento è disponibile un'opzione tramite menù contestuale sul documento chiamata Word wrap o anche tramite la barra strumenti di Edit. Tale opzione consente di attivare l'a capo automatico in fase di editing; in fase di visualizzazione è attivo comunque. Per ammissione del produttore stesso, tale opzione non funziona correttamente, quindi può capitare di averla attiva ma non funzionante. In tal caso basta disattivarla e riattivarla nuovamente. Il problema verrà risolto con la prossima uscita del programma (fra breve).

Caratteri speciali

Considerando che Internet permette la comunicazione fra sistemi operativi diversi e nazioni diverse, alcuni caratteri possono dare incompatibilità. Per questo motivo andrebbero sempre sostituiti con degli strani codici che garantiscono la compatibilità totale. Con 1st Page non è necessario ricordarsi tali codici a memoria ma basta ricorrere alla finestra di visualizzazione caratteri e selezionare quello di interesse; con un doppio click esso verrà inserito correttamente nel punto di inserimento del documento attivo. Per richiamare la tabella:
Menù: [View->Special character symbols]
Easy: Properties->View special characters list
Expert:View->View Extended Characters (c'è disegnata una C); la toolbar View è quella che sta in alto a sinistra nella seconda riga. In pratica se non avete modificato le opzioni, non fa parte della Tooltab.

Come potete notare, anche le doppie virgolette, i segni di maggiore e minore e la e commerciale fanno parte dei caratteri speciali. Un 'non breaking space' cioè uno spazio che separa due parole che dovrebbero stare su una stessa riga, può comodamente essere inserito da: Expert->Standard->Non Breaking Space.

Un piccolo trucco: se non avete la pazienza di selezionare di volta in volta i caratteri speciali, stilate il documento usando i caratteri della tastiera e poi effettuate le sostituzioni in seguito (l'importante è ricordarsi di farle!).

Un altro trucco (ancora più comodo): andare sul menù: [Options->Editing Preferences->Auto Correct]: qui è possibile impostare delle correzioni automatiche. Questo strumento è utilissimo al nostro scopo in quanto basterà impostarlo affinché sostituisca tutti i caratteri normali (digitati sulla tastiera) con quelli speciali e la sostituzione avverrà in automatico ogni volta che digiteremo tale carattere. La sostituzione avviene se il carattere o la sequenza di caratteri è seguita da uno spazio. Quindi ricordatevi di mettere uno spazio dopo i caratteri speciali (se non volete lo spazio digitatelo ugualmente in modo che avvenga la correzione automatica, dopodiché lo cancellate con BACKSPACE). Il fatto che debba essere digitato lo spazio è comunque comodo perché se si vogliono sostituire ad esempio i simboli di < e >, quando inseriamo un comando come ad esempio <BODY>, esso verrà lasciato giustamente inalterato. 

Un terzo metodo di sostituzione dei caratteri speciali consiste nella sostituzione a documento terminato tramite lo strumento Tidy HTML. 

Inserire commenti

I commenti sono parti di testo non visibili all'interno del browser. Possono essere utilizzati per commentare il codice, oppure possono contenere informazioni sull'autore, e sul sito, il che può essere utile perché le pagine in formato HTML sono comunque facilmente visibili nel loro formato originale. Il tasto apposito presente sulla toolbar Expert è: Standard->Comment. Oppure dal menù contestuale: HTML->HTML Comment. Infine è molto utile la funzione presente su menù contestuale: dopo aver selezionato la parte di testo da trasformare in commento andare su: Selected->Comment this text. 

Formattazione del testo

Se ci si limita ad inserire del testo all'interno di una pagina web, senza nessuna formattazione, esso apparirà con le caratteristiche standard, quindi con un carattere Times New Roman, dimensione normale, nero su sfondo grigio chiaro, allineato a sinistra. Con l'impostazione del tag BODY visto in una precedente lezione, è però possibile modificare tale impostazione di base. Se però non ci limitiamo a creare pagine dall'aspetto molto spartano, ci sono buone possibilità che si voglia intervenire su singole porzioni del testo per fargli assumere un aspetto particolare. Grosso modo come accade con l'utilizzo di un programma di videoscrittura, c'è la possibilità di formattare uno o più caratteri (tipo e dimensione del font, grassetto, corsivo, sottolineato, ecc.), l'aspetto generale di uno o più paragrafi (allineamento del testo, titoli, ecc.) e intere sezioni contenenti sia testi che immagini (allineamento). 

La formattazione può essere di tipo logico o fisico. Mentre con una formattazione di tipo fisico si indica direttamente il risultato che si vuole ottenere graficamente (es. grassetto o allineamento centrato), con quello logico si indica lo stile che si vuole applicare ad una parte del testo e la formattazione fisica è una conseguenza dello stile scelto (ad es., se indico che voglio un titolo di 1° livello, ottengo un testo più grande e con una certa spaziatura prima e dopo). N.B.: La formattazione logica qui indicata si ottiene sfruttando direttamente l'HTML di base senza fogli di stile (CSS). Utilizzando i CSS è possibile modificare l'impostazione dei vari stili e crearne di nuovi, cosa che non si può fare con l'HTML puro.

Considerazioni generali
Vorrei sottolineare che qualsiasi comando di formattazione può essere richiamato dopo aver selezionato una porzione di testo in modo da ottenere automaticamente l'inserimento del codice in maniera da formattare la parte di testo selezionata.
Inoltre molti comandi di seguito descritti, sono richiamabili anche tramite menù contestuale HTML. Eviterò di indicare tale funzione ogni volta.
Sulla barra Hardcore->Text Formatting è presente una lista completa di codici di formattazione del testo. 

Formattare i caratteri
Un comodo strumento presente in 1st Page è il Font Tag Editor richiamabile in questo modo:

· Menù: [Format->Font] 

· Easy: Layout->Font Tag Editor 

· Expert: Fonts->Font Tag Editor 

Questo strumento consente di impostare velocemente e tramite un'unica finestra di dialogo, diverse impostazioni relative ai caratteri. Le varie impostazioni verranno viste separatamente.

Formattazione fisica
Tipo di Font

Il Font Tag Editor contiene al suo interno una lista dei font disponibili, ognuno visualizzato con se stesso (cioè ogni font contiene un'anteprima). È una cosa molto utile purtroppo assente in molti programmi commerciali, non solo di creazione siti Internet. Occorre però una certa attenzione nella scelta di un carattere. Infatti non è detto che tutti i possibili lettori della nostra pagina abbiano disponibile sul proprio computer il carattere che abbiamo scelto noi. Perciò è buona norma indicare anche delle alternative o, ancora meglio, delle famiglie di caratteri (in pratica un gruppo di caratteri simili) in modo che, se chi visualizza la nostra pagina non ha a disposizione un certo carattere, vengono fornite una o più alternative. Anche in questo caso 1st Page ci viene in aiuto tramite il menù: [Tags->Common Font Faces]. Qui vengono elencati alcuni dei font più comuni e alcune combinazioni di quelli che si somigliano maggiormente. È possibile selezionando una delle voci, avere direttamente il codice che fornisce le varie alternative di visualizzazione (le alternative vengono cercate a partire dalla prima indicazione a sinistra in poi).

Dimensione dei Font
L'HTML prevede 7 dimensioni. Esse possono essere indicate in maniera assoluta con numeri da 1 a 7 oppure in relazione al font utilizzato in precedenza tramite dei numeri preceduti dal segno meno per diminuire e dal segno più per aumentare (per es. +1 significa che voglio aumentare il font di 1 rispetto alla dimensione attualmente utilizzata). Le dimensioni assolute consentono un maggior controllo sul risultato (ma non è detto che sia adatto alla risoluzione utilizzata dal lettore), mentre quelli relativi danno delle indicazioni di massima più adattabili alle varie situazioni. Tramite il Font Tag Editor sono utilizzabili entrambi i metodi. In alternativa è possibile utilizzare i bottoni della barra Expert: Fonts->Decrease font size e Fonts->Increase font size. Essi inseriscono rispettivamente il codice SMALL e BIG che modificano di 1 punto per volta la dimensione; possono essere utilizzati anche più volte in sequenza (ad esempio per ottenere -2 si inserisca 2 volte il codice SMALL). Personalmente preferisco i codici numerici perché più leggibili. 

Gestione Colori
Nel Font Tag Editor è disponibile una comoda tavolozza colori che, una volta selezionato un colore di base, consente di modificarlo agendo sulle tonalità RGB (rosso, verde, blu). Viene inoltre visualizzato il codice del colore e premendo sul tasto '!' a fianco al codice del colore, esso viene copiato negli appunti di Windows in modo da poterlo incollare dove occorre. È comunque un'operazione superflua normalmente perché il codice viene comunque inserito automaticamente sulla finestra principale del font tag editor.
A proposito di gestione colori, consiglio a chi non lo avesse ancora fatto, di leggere il capitolo apposito. 

Posizione del testo
I bottoni Expert Fonts->Subscript e Fonts->Superscript consentono di inserire testo in posizione inferiore e superiore alla normale riga di scrittura. Tali opzioni sono presenti anche sul Font Tag Editor (Text Position). 

Altro
Possiamo applicare anche: 

· grassetto o bold 

· corsivo o italic 

· sottolineato o underlined 

· lampeggiante o blink (funziona solo su Netscape) 

· barrato o strike (barrato o strike) 

· teletype 

Sono tutti richiamabili sia dal Font Tag Editor che dalla barra Expert. 

Formattazione logica
Effettuabile sempre dal Font Tag Editor (in cui sono visibili anche i risultati in anteprima) e dalla barra Expert. Segue un breve elenco: 

· Citazione o Citation; 

· Codice o Code: usato in genere per inserire parti di codice in linguaggi di programmazione; 

· Emphasis: per enfatizzare il testo; 

· Tastiera o Keyboard: per indicare il testo che deve digitare l'utente; 

· Sample: sequenza di caratteri letterali; 

· Strong: mette in evidenza; 

· Variable: indicato per definire variabili; 

Formattare i paragrafi
Formattazione fisica

Un paragrafo è delimitato dal tag P. Esso può contenere anche l'indicazione dell'allineamento a destra, al centro, a sinistra e, solo per i browser dalla 4^ generazione in poi, anche giustificato (era ora!!!). L'unico metodo per inserire velocemente un nuovo paragrafo con tanto di indicazione sull'allineamento consiste nell'utilizzare il tasto destro: HTML->Alignment->Paragraph...;oltre naturalmente alla solita barra Expert: Fonts->Align...; si può anche andare a capo senza definire la fine di un paragrafo, in questo caso basta premere il tasto Expert: Standard->Break; andare a capo senza creare un nuovo paragrafo consente di continuare a scrivere su una nuova riga, con lo stesso allineamento già definito e senza nessuno spazio aggiuntivo. Nella maggior parte dei casi non si nota la differenza fra creazione di un nuovo paragrafo ed inserimento di un BREAK, ma se il paragrafo ha una formattazione logica particolare la differenza si nota. Ad esempio per avere un titolo di 1° livello su due righe va utilizzato il BREAK in quanto diversamente le due righe verrebbero formattate come se fossero due titoli diversi (con tanto di spaziatura verticale aggiuntiva). Il paragrafo centrato è ottenibile anche con il comando CENTER disponibile, oltre che sul menù contestuale, anche tramite menù: [Tags->Center align].
Nel menù contestuale potete notare che non esistono solo 3 opzioni di allineamento ma ben 7: questo perchè sono stati creati nel tempo diversi tag di allineamento. Non mi risulta che ci siano dei tag preferenziali rispetto ad altri.

Personalizzazione tag allineamento su barra Expert
Utilizzando la barra Expert, vengono inseriti certi tag di allineamento. Se se ne vogliono usare degli altri, basta andare sul menù: [Options->General Program Preferences->HTML Tags]; sulla parte destra della schermata c'è la possibilità di indicare il tag che si preferisce venga inserito premendo i 3 tasti di allineamento. 

Formattazione logica
Titoli

Prima di tutto abbiamo la possibilità di definire 6 livelli gerarchici di titoli. I due metodi di inserimento utilizzabili sono i soliti: menù contestuale: HTML->Format->Heading..; barra Expert: Fonts->Heading levels; è consigliabile usarli sia per mettere facilmente in evidenza i titoli, sia per mantenere una formattazione comune tra i titoli dello stesso livello ed infine per facilitare i motori di ricerca che ultimamente danno una certa importanza ai titoli.

Liste
Ci sono poi le liste che, sulla barra Expert hanno una voce completamente dedicata. Purtroppo però, sul programma che ho installato io in questo momento, alcuni tasti sono stati invertiti, in particolare le icone sono errate, ma la scritta che appare corrisponde al comando che viene inserito, quindi attenzione al loro utilizzo.
Due dei tasti sono molto intuitivi (bullet list o lista puntata e numbered list o lista numerata) e consentono la creazione di una nuova lista; al suo interno, per l'inserimento di ogni elemento, andrà premuto il tasto list item.
Segue poi la menu list i cui elementi si inseriscono sempre con il tasto list item.
Per quanto riguarda la definition list, gli elementi sono formati da titolo e descrizione; la definizione del primo elemento è inserita in automatico. Non è stato aggiunto un tasto unico per l'inserimento dei nuovi elementi ma due tasti: uno per il titolo (definition term) ed uno per la descrizione (definition). Considerate che con lo stesso codice delle liste numerate si possono creare anche liste alfabetiche o liste numeriche con numeri romani (vedi lezioni HTML).
Consiglio: c'è un metodo ancora più veloce per creare o trasformare del testo in liste: basta scrivere il testo andando a capo con INVIO (senza bisogno di inserire BR a fine riga) alla fine di ogni elemento e poi, dopo aver selezionato il testo andare sul menù contestuale: Selected->Convert Lines to Ordered List (o Unordered List) e il gioco è fatto. 
Infine qualcuno potrebbe chiedersi: "Come si fa ad inserire delle liste che al posto del solito punto in formato testo utilizzano un'immagine?". Esistono alcuni programmi che effettuano tale operazione automaticamente, ma 1st Page non è fra questi. Comunque l'effetto si ottiene senza difficoltà creando una tabella (vedi). 

Formattare le sezioni
È possibile impostare parti particolari del documento con tanto di allineamento (usando i CSS si può fare molto di più). Tramite menù contestuale: HTML>Alignment->DIV...
Questa è la stessa opzione già vista per l'allineamento dei paragrafi, ma quest'ultimo comando è forse più indicato per la formattazione di lunghe sezioni contenenti magari anche immagini, tabelle ed altri elementi. 

Linee orizzontali
Inoltre, tramite la barra Expert: Standard->Horizontal Line, o Easy: Extras->Horizontal Rule o menù: [Insert->Horizontal Rule], è possibile inserire linee divisorie definendone le caratteristiche dalla finestra di dialogo. Possiamo indicare la lunghezza assoluta o in percentuale (Line Width), la larghezza (Line Tickness), l'allineamento ed eventualmente, disabilitare l'ombreggiatura; il tutto con l'anteprima del risultato. Andando sulla scheda "Browser Specific" è possibile poi cambiare colore alla linea (come indicato l'opzione colore funziona solo su Explorer).
Per richiamare il semplice tag di inserimento linea andare su Hardcore: Block->HR.

Il controllo ortografico e le altre opzioni che vedremo in questa lezione sono disponibili solo per la lingua inglese. I dizionari hanno estensione ICT e ne possono essere aggiunti degli altri. Il controllo ortografico può essere avviato tramite menu: [Tools->Check Spelling] o barra Expert Quick Tools->Check Spelling e presenta le classiche opzioni di un controllore ortografico. I nuovi dizionari possono essere aggiunti dopo aver richiamato il controllo ortografico, andando su OPTIONS.

Controllo durante la digitazione

Si attiva/disattiva tramite il menu [Tools->Live Spell] o il tasto Quick Tools->LiveSpell e consente di correggere le parole errate tramite menu contestuale. 

Dizionario dei sinonimi

Il controllo ortografico e le altre opzioni che vedremo in questa lezione sono disponibili solo per la lingua inglese. I dizionari hanno estensione ICT e ne possono essere aggiunti degli altri. Il controllo ortografico può essere avviato tramite menu: [Tools->Check Spelling] o barra Expert Quick Tools->Check Spelling e presenta le classiche opzioni di un controllore ortografico. I nuovi dizionari possono essere aggiunti dopo aver richiamato il controllo ortografico, andando su OPTIONS.

Controllo durante la digitazione

Si attiva/disattiva tramite il menu [Tools->Live Spell] o il tasto Quick Tools->LiveSpell e consente di correggere le parole errate tramite menu contestuale. 

Dizionario dei sinonimi

Anche questo è sul menu [Tools->Thesaurus Lookup] e sulla barra Expert Quick Tools->Thesaurus Lookup e consente anche di impostare dei filtri (ad esempio per trovare solo nomi o solo verbi).

L'inserimento di immagini è facilitato da alcuni strumenti reperibili sia sulla barra Easy sia su quella Expert:

· Il primo strumento, da Easy: Image->Insert Image Quickly o da Expert: Standard->Insert Image Quickly, consente di scegliere il percorso dell'immagine da inserire ed inserisce automaticamente il codice contenente anche i parametri relativi alle dimensioni (vengono impostate le dimensioni originali), al bordo (impostato a 0, cioè assente) e al testo alternativo (lasciato in bianco). A questo punto è possibile andare a modificare direttamente dal codice eventuali parametri, per esempio inserire il testo alternativo e modificare le impostazioni del bordo.
È possibile impostare il programma in modo che inserisca automaticamente come testo alternativo il nome del file. Per modificare tale impostazione andare sul menu: [Options->General Program Preferences->Side File Explorer->"Insert file details in ALT description attribute"]. La stessa impostazione ha anche effetto sul trascinamento di un'immagine dal File Explorer: in tal caso, con l'opzione abilitata, si avranno oltre il nome del file, anche le sue dimensioni. 

· Ne consegue che un modo immediato per inserire un'immagine, se si utilizza il File Explorer, consiste nel trascinare il nome dell'immagine direttamente sul documento. Il risultato è molto simile a quello dello strumento appena visto. 

· Il secondo strumento consente di effettuare diverse impostazioni da una finestra di dialogo e consente inoltre di avere un'anteprima delle immagini. Per utilizzarlo scegliere da Easy: Image->Image Tag Editor o da Expert: Standard->Image Advanced. La stessa opzione è presente anche sul menu: [Insert->Image]. Sulla destra della finestra di dialogo è presente un piccolo File Explorer, ma consiglio di premere sulla cartellina che apre la tipica finestrella di apertura file presente sulla maggior parte dei programmi, però con il tastino aggiuntivo di creazione nuova cartella e soprattutto con l'anteprima delle immagini. Viene automaticamente attivata un'anteprima non animata, ma premendo sul tastino "anteprima" in alto a destra, si apre una finestrella con l'immagine in dimensioni originali e parte l'eventuale animazione. Inoltre questa finestra di dialogo parte con la visualizzazione della cartella in cui si trova il documento web e poi memorizza l'ultimo percorso utilizzato per la ricerca di immagini. Utilizzando invece l'esplorazione files posta sulla destra della finestra principale, si ha la noia di dover ripartire ogni volta dal Desktop, ma in compenso si ha l'anteprima direttamente in dimensione originale e con animazione. Le dimensioni dell'immagine vengono calcolate automaticamente, possono essere modificate, purtroppo senza l'opzione "mantieni proporzioni", però si può tornare a quelle originali premendo il tasto "Recalculate". Il testo alternativo non viene impostato in automatico, ma può essere comodamente inserito da qui. Si può inoltre modificare la dimensione del bordo con anteprima del risultato e le spaziature verticali ed orizzontali. Premendo il tasto ADVANCED (in alto), possiamo impostare l'immagine come mappa (nella prossima versione ci sarà una gestione completa delle mappe immagine); si può impostare un'immagine LOWSOURCE, cioè una immagine di dimensione minore che viene caricata in attesa del caricamento dell'immagine finale e il nome dell'immagine, utile soprattutto se si utilizzano degli script per modificarne le impostazioni. Infine in basso troviamo alcune opzioni valide solo per Internet Explorer. 

· Il terzo strumento è particolare in quanto inserisce del codice JavaScript per gestire l'effetto "rollover", cioè il caricamento di un'immagine diversa nel momento in cui ci si posiziona sull'immagine col mouse. La creazione di tale effetto non crea nessuna difficoltà grazie a questo comodo wizard. Dalla barra Easy: Image->Insert Rollover Image; da Expert: Standard->Insert Rollover Image; dal menu: [Insert->Javascript Rollover Image]. A questo punto basta indicare il nome dell'immagine normale, un nome identificativo unico (che serve allo script per identificare l'immagine su cui lavorare), il nome dell'immagine da visualizzare quando il mouse si sposta sopra ed il gioco è fatto. Eventualmente si può anche aggiungere un link ed il testo alternativo. 

	Consiglio: inserite sempre il testo alternativo perché è utile per chi non visualizza le immagini (c'è qualcuno che lo fa) ed anche per i non vedenti che utilizzano un programma che legge il contenuto della pagina web, incluso il testo alternativo per le immagini. 


Modificare le impostazioni di un'immagine
Per modificare le impostazioni di un'immagine, basta posizionarsi all'interno del tag che contiene i relativi comandi e, scegliere la voce del menu contestuale Edit Tag IMG. A questo punto ci si ritrova all'interno dello strumento di impostazione immagini e si possono fare tutte le modifiche che si desiderano. Oppure si può uscire da tale finestra e poi premere CANC per eliminare l'intero codice relativo (che rimane selezionato). 

Visualizzare un'immagine già inserita
Capita a volte di voler verificare a quale immagine si riferisce un link inserito all'interno di una pagina. Abbiamo già visto che è possibile usare il comando EDIT TAG IMG del menu contestuale per aprire il wizard per le immagini all'interno del quale c'è anche l'anteprima.
Ma se vogliamo solo vedere l'immagine, si può semplificare ulteriormente l'operazione scegliendo, sempre dal menu contestuale, la voce Preview Image che ci visualizza immediatamente l'immagine con le dimensioni originali all'interno di una finestrella con eventuale animazione. Da qui sarà anche possibile premere sulla cartellina aperta per scegliere di vedere altre immagini in anteprima. 

Aprire un'immagine con l'editor associato
1st Page può essere impostato in modo che sia possibile aprire un'immagine all'interno di un editor o comunque di un programma che ne supporti la visualizzazione, tramite una voce del menu contestuale.
Per impostare il nome del programma che si desidera utilizzare andare sul menu: [Options->General Program Preferences->General->Image Editor] ed impostare il nome del programma che si preferisce utilizzare.
Una volta effettuata tale impostazione, sarà possibile dopo aver inserito il link relativo ad un'immagine all'interno di un documento, richiamare il menu contestuale da un qualunque punto interno al tag IMG e scegliere la voce: Edit in Image Editor.

Immagino che tutti voi sappiate cosa è un link (collegamento) ipertestuale. Comunque, per chi non lo sapesse, semplificando e tralasciando i servizi meno utilizzati, è costituito da un testo, un'immagine o un bottone che, se cliccato, porta il navigatore ad una pagina diversa, o ad una parte della pagina, oppure consente di inviare un'e-mail. I link sono riconoscibili dal fatto che passandoci sopra il puntatore del mouse, esso assume una forma diversa (generalmente quella di una mano con l'indice puntato). L'utilizzo dei link all'interno di un sito web è fondamentale.

Utilizzo della finestra di dialogo
La finestra di dialogo è richiamabile nei seguenti modi:

· Easy: Anchor; 

· Expert: Standard->Anchor External; 

· Hardcore: In-line/Media->Anchor Tag Editor; 

· menu: [Insert->Anchor/Link]; 

Considerando che quello HTTP che consente di visualizzare i siti internet, è solo uno dei servizi Internet disponibili, dalla finestra di dialogo è possibile selezionare il servizio desiderato. 

Inserire un link ad un'altra pagina del proprio sito (link interno)
Per inserire un link ad un'altra pagina del proprio sito, non è nemmeno il caso di selezionare il servizio, ma basta premere sul tasto a forma di cartellina aperta e selezionare la pagina desiderata. Verrà così creato un collegamento relativo, cioè a partire dalla cartella su cui si trova la pagina. Consiglio di lasciare il link così come viene creato, in modo che funzioni indipendentemente da dove viene salvato o pubblicato il sito. 

Inserire un link ad un altro sito (link esterno)
Anche in questo caso la scelta del servizio non è necessaria, è utile solo se si digita direttamente l'indirizzo del sito. È presente una comoda funzione: premendo il secondo tasto a forma di cartellina (quello sulla destra), compare un piccolo menu che permette di inserire, oltre i link alle varie pagine di EvrSoft, anche tutti i link che vengono automaticamente importati dai Preferiti di diversi browsers. 

Altre opzioni della finestra di dialogo
Nel campo Target, è possibile decidere dove si vuole aprire il collegamento. Selezionando _blank, esso viene aperto in una nuova finestra e con _self, viene caricato al posto della pagina che lo richiama. Nel caso la pagina su cui si inserisce il link contenga dei frames, l'opzione _parent caricherà la pagina sul frame immediatamente precedente a quello presente, l'opzione _self la caricherà sul frame in cui è presente il link, l'opzione _top eliminerà tutti i frames e caricherà la nuova pagina sulla stessa finestra; infine è possibile digitare direttamente il nome del frame in cui caricare la pagina.
Sul campo NAME si può indicare un nome da assegnare alla finestra o al frame che conterrà la nuova pagina (può servire per gestirla tramite script o per indicarla in seguito come TARGET per il caricamento di un altro documento.
Sul campo DESCRIPTION è possibile indicare il testo da visualizzare per richiamare il link.
Si può poi definire su STATUSBAR, del testo che andrà visualizzato sulla barra di stato quando il mouse passa sul link.
Infine si può decidere di visualizzare il link come bottone anziché come semplice scritta.
In basso troviamo due ulteriori opzioni valide solo per Explorer, la prima consente di visualizzare un Tooltip (breve testo descrittivo visualizzato all'interno di una bandierina gialla) quando si passa sul link col mouse, ed il secondo consente di impostare un tasto di scelta rapida per attivare il link. Ad esempio posso impostare il tasto ALT+R per richiamare il link alla pagina "Registrazione". 

Inserire immagini contenti link
Non è stato previsto un metodo facilitato per inserire immagini contenti link. Quindi credo che il metodo più veloce per farlo consista nell'inserire il link normalmente, lasciando in bianco il campo DESCRIZIONE, e poi posizionarsi col cursore subito prima della scritta </a> e inserire l'immagine (col metodo che si preferisce). 

Utilizzo dei segnalibri (anchors o target)
All'interno di un'unica pagina, è possibile identificare diversi punti richiamabili tramite link. Immaginiamo ad esempio un lungo elenco di parole in ordine alfabetico: all'inizio della pagina possiamo inserire dei collegamenti alle diverse lettere dell'alfabeto. Quindi cliccando su 'F', ci ritroviamo immediatamente a visualizzare tutte le parole che iniziano con la F. Per ottenere un effetto di questo tipo bisogna fare due operazioni diverse: 

Inserimento di un segnalibro
L'unica barra che contiene uno strumento di inserimento veloce è la barra Expert: Standard->Insert Target; a questo punto basta inserire all'interno delle doppie virgolette il nome che si intende dare al segnalibro (ad esempio 'F'); da questo momento in poi sarà possibile visualizzare la pagina corrente a partire dal punto in cui è presente tale segnalibro. 

Collegamento ad un segnalibro
È un collegamento come gli altri, con l'unica differenza che anziché indicare un indirizzo o il nome di una pagina, si indica il carattere # seguito dal nome del segnalibro. Lo strumento di inserimento rapido si trova a fianco a quello visto precedentemente ed è: Standard->Goto Target. Ricordatevi di inserire il testo o l'immagine che richiamerà il link subito prima del testo </a>, altrimenti il link non sarà visibile e quindi nemmeno utilizzabile. 

Collegamento ad un segnalibro su una pagina diversa
Consiglio di utilizzare lo strumento che ho illustrato prima per inserire i collegamenti a pagine e siti. L'unica operazione aggiuntiva da fare consiste nell'aggiungere all'interno del link il carattere # seguito dal nome del segnalibro (ad esempio: "index.htm#F").

Nota
Utilizzando lo strumento di creazione link per indicare un collegamento e compilando anche il campo NOME, si crea in un unico passaggio sia un collegamento che l'assegnazione di un segnalibro. Sarà quindi possibile indicare in un'altra parte del documento un link a tale link. 

Collegamento ad un indirizzo e-mail
Cliccando un link di tipo email, viene aperto il programma di posta predefinito contenente un nuovo messaggio in cui alcuni campi possono essere già compiltati (a seconda di come viene creato il link). La creazione di questo tipo di link è facilitata da diversi strumenti:

· C'è uno strumentino apposito che però è nascosto (l'ho scoperto per caso). Infatti non è presente su nessuna barra strumenti ma è richiamabile dal menu: [Insert->E-mail]. A questo punto compare una finestrella in cui è possibile compilare alcuni campi. Il campo E-MAIL conterrà l'indirizzo e-mail del destinatario; il campo SUBJECT l'eventuale oggetto (vedi più avanti in questo paragrafo per la compatibilità); il campo DESCRIPTION contiene invece il testo che appare nel browser come indicazione del link (ad esempio: "premi qui per mandarmi un'email"); infine STATUSBAR, come già visto prima consente di impostare un testo che verrà visualizzato nella barra di stato solo quando il mouse del visitatore si posiziona sul link. 

· Ma il modo più semplice per creare un collegamento e-mail consiste nel premere l'apposito bottone su Expert: Standard->E-mail to; a questo punto basta inserire l'indirizzo di posta elettronica e il testo descrittivo.

· Oppure si può usare lo strumento di creazione collegamenti visto nel paragrafo precedente; si sceglie come servizio quello "mailto:" e si aggiunge l'indirizzo direttamente nel campo URL. 

Precompilare i campi dell'e-mail e compatibilità
C'è la possibilità di indicare anche altri dati, ad esempio l'oggetto, uno o più destinatari in copia carbone e anche il testo del messaggio, ma purtroppo queste opzioni non sono universalmente compatibili. Ad esempio il campo TITLE (per l'oggetto) è riconosciuto solo da Mosaic e Explorer mentre in Netscape l'oggetto si inserisce come SUBJECT. Segue un esempio contenente diversi campi e riconosciuto presumibilmente solo da Explorer + Outlook Express:
<A HREF="mailto:user@domain.it?subject=Oggetto dell'email&cc=cc@domain.it&body=Testo e-mail">Premi qui</A>
Consiglio: per aprire il programma di posta predefinito con un messaggio vuoto senza indicare il destinatario, basta inserire il link mailto: senza nessun indirizzo. Ricordatevi chiaramente di inserire il testo (o l'immagine) sempre prima di </a>.
Per creare un collegamento e-mail richiamabile tramite un pulsante, vedere lo strumento di creazione collegamenti all'inizio di questa stessa lezione. 

Collegamento ad un server FTP
Basta scegliere il relativo servizio dalla lista (sempre tramite lo stesso strumento già visto). Il server FTP verrà visualizzato direttamente nel browser, se lo stesso lo consente. Nel caso sia richiesta user-id e password, essi verranno richiesti (sempre se la cosa è supportata dal browser). 

Altri servizi
Sono disponibili altri servizi (come telnet, newsgroup, gopher, ecc.). 

Altri modi per inserire i link
· Utilizzando il File Explorer, basta trascinare il nome di un file sul documento in lavorazione e verrà creato automaticamente un link contenente il nome del file. Basterà aggiungere la descrizione direttamente nel punto di inserimento. 

· La stessa operazione può essere effettuata anche dal Project Manager. 

· Dal menu contestuale scegliere la voce Make Link. 

· Dalla barra Hardcore: In-line/Media->Anchor. 

· Dal menu: [Insert->Link to Local File]. 

· Dalla barra Expert: Standard->Anchor - Local. 

Gli ultimi due sono consigliati per i collegamenti interni.

Presentazione

Questo capitolo vuole essere una breve presentazione delle possibilità offerte da 1st Page per la ricerca e sostituzione di testo, per lo spostamento veloce all'interno di uno o più documenti, per l'inserimento di segnalibri (che non hanno niente a che fare con quelli in HTML), per trasformare testo da maiuscolo a minuscolo e viceversa, per vedere il contenuto degli appunti, ecc. 

Barra Navigation

Partiamo con l'analisi della barra Navigation presente sulla barra strumenti Expert. 
Qui troviamo i primi 2 bottoni già visti che consentono di posizionarsi sul tag HEAD e su quello BODY.
Poi abbiamo altri 2 tasti per posizionarsi alla fine ed all'inizio del documento.
Seguono 4 tasti di navigazione tra documenti aperti. Gli stessi tasti si trovano anche sulla DOCUMENT BAR, quella posta in basso a sinistra (che può essere spostata) e che contiene anche le linguette con i nomi dei documenti aperti.

Strumento Find
Lo strumento Find merita un paragrafo a parte in quanto è particolarmente ben concepito. Le opzioni sono abbastanza immediata da capire:

· innanzitutto come testo da cercare viene conservato uno storico che non viene cancellato nemmeno chiudendo il programma; 

· su ORIGIN possiamo scegliere se cercare solo dal cursore in poi o in tutto il documento; 

· su DIRECTION possiamo decidere di cercare in avanti (FORWARD) o indietro (BACK) 

· su OPTIONS, oltre le opzioni tipiche di CASE SENSITIVE, cioè ricerca solo il testo rispettando maiuscole e minuscole e WHOLE WORDS, cioè ricerca di sole parole intere, abbiamo anche REGULAR EXPRESSIONS che consente di inserire particolari espressioni nella ricerca. Per averne qualche esempio premete il tasto REG sulla destra della stringa di ricerca e vedete la lista. Oltre a poter inserire la ricerca di caratteri non visibili come l'INVIO o il TAB, si possono fare ricerche parametriche: per esempio "naviga* bar*" potrebbe trovare sia "navigation bar" che "navigazione barra". 

· Infine un ultimo semplice ma comodo parametro consente di chiudere la finestra automaticamente dopo la ricerca. 

Se poi vogliamo cercare di nuovo in base agli stessi parametri, basterà premere il tasto Find Next. 
Un terzo tasto Mark all found maches, consente di evidenziare tutto il testo che corrisponde ai parametri di ricerca impostati. Va premuto dopo aver effettuato la ricerca della prima occorrenza. 

Sostituzione di testo
Si richiama sempre dalla barra Navigation->Replace. Il funzionamento e le opzioni sono gli stessi già visti per lo strumento FIND. Anche in questo caso c'è una ricca cronologia sia del testo cercato che di quello con cui è stato sostituito. Si può sostituire una sola occorrenza o tutte insieme e si può decidere di confermare ogni sostituzione o meno. Il tasto REGULAR EXPRESSIONS ha la stessa funzione di quello visto per FIND, anche se purtroppo qui non è stata inserita la lista di variabili utilizzabili. 

Strumento di Autocorrezione
Tale strumento è stato già presentato nel capitolo dedicato all'inserimento di testi e può essere usato per sostituire del testo durante la digitazione. Si può sfruttare sia, come già visto, per l'inserimento di caratteri speciali, sia per velocizzare l'inserimento di testi lunghi e ripetitivi che potranno essere richiamati tramite un'abbreviazione, sia per correggere in automatico alcuni errori di digitazione (ad esempio la è con la é). 

Numeri di riga
Quando ci si trova in modalità EDIT, sulla sinistra appare una barra verticale con diversi pulsanti. Abbiamo già visto quello di chiusura rappresentato da una X rossa. Ora vediamo gli altri.
Innanzitutto è possibile visualizzare i numeri di riga (molto utile in caso di script che danno errore perché il browser segnala il numero di riga dell'errore). Per attivare questa opzione, bisogna attivare sia il bottone SHOW GUTTER che quello SHOW LINE NUMBERS. L'a capo automatico non crea nuove righe, infatti tali righe non sono numerate ma segnate con un simbolo di invio. L'a capo automatico può essere disattivato tramite il tasto WORD WRAP. Sulla barra strumenti navigazione ho tralasciato di proposito l'ultimo bottone Goto line number che consente di spostarsi velocemente ad un certo numero di riga.
Sia che i numeri di riga siano visualizzati o meno, possiamo comunque vedere la posizione del cursore all'interno della pagina tramite due numeri visualizzati in basso a sinistra: il primo indica la riga ed il secondo la colonna corrente. In questo caso però, se abbiamo attivato l'a capo automatico, i numeri di riga non saranno quelli effettivi.
Abbiamo poi SHOW ALL HIDDEN CHARACTERS che consente di visualizzare i caratteri invisibili (tab, spazio, invio, ecc.) 

Segnalibri
Il tasto PLACE BOOKMARK consente di inserire fino a 10 segnalibri per raggiungere rapidamente un certo numero di riga. Vi lascio indovinare a cosa serve GOTO BOOKMARK ;)
Per sostituire un bookmark, basta inserirlo dalla nuova posizione. Per eliminarlo andare nuovamente su PLACE BOOKMARK (dalla stessa riga) o su PLACE BOOKMARK->REMOVE ALL per eliminarli tutti insieme. 

Evidenziare il testo
Durante l'editing di un documento può risultare utile utilizzare un evidenziatore per alcune parti del documento. Questo può essere effettuato, dopo aver selezionato il testo da evidenziare, tramite Highlight Pen->Highlight Selected Text. Dallo stesso menu si possono anche rimuovere tutte le evidenziazioni.
N.B.: Le impostazioni di evidenziazione non vengono salvate. 

Anteprima in tempo reale
Il tasto REALTIME LOGISTICS PREVIEW consente di suddividere in 2 parti la finestra in modo da avere una parte dedicata all'edit e l'altra al preview.
Tramite il successivo tasto ADJUST REALTIME PREVIEW si apre un piccolo menu in cui si può scegliere se avere la suddivisione in finestre orizzontali o verticali ed eventualmente scambiarle tra loro (SWAP WINDOW PANES). L'ultima voce (UPDATE/REFRESH PREVIEW) consente di aggiornare la vista, anche se in genere viene aggiornata in automatico. L'utilizzo di questo strumento può rallentare un po, ma è comodo, soprattutto in fase di rilettura di un documento. Per eliminare l'anteprima basta premere nuovamente il bottone REALTIME LOGISTICS PREVIEW. 

Selezione rapida di un tag

Se vogliamo selezionare velocemente un tag (cioè il codice HTML compreso fra i segni di minore e maggiore), basta posizionarsi all'interno dello stesso e poi premere il bottone Select Tag della barra View (in modalità Expert sulla sinistra dello schermo subito dopo i tasti di Annullamento e Ripetizione. 

Testo minuscolo o maiuscolo?

Per trasformare velocemente del testo in maiuscolo o in minuscolo, selezionatelo e poi tramite menu contestuale, scegliete: Selected->To Uppercase per convertire il testo selezionato in maiuscolo o Selected->To lowercase per convertirlo in minuscolo. Le stesse opzioni sono presenti anche sul menu: [Edit->Convert Selection Case->...]. 

Maiuscole o minuscole per i tags?

Tramite menu: [Edit->Insert Tags in Uppercase] è possibile decidere se si vuole che i comandi inseriti tramite 1st Page siano maiuscoli o minuscoli. Tale opzione non agisce sui tags già inseriti. Per modificare questi ultimi vedi il capitolo sulla conversione delle pagine. 

Conteggio caratteri

Nel menu contestuale è presente una funzione di calcolo dei caratteri: Selected->Character count. Tale opzione conta solo i caratteri selezionati, inclusi gli spazi. 

Visualizzazione Appunti

Il contenuto degli appunti (solo testo) può essere visualizzato tramite [Tools->Windows clip 'o' board]

Impostazione browser esterni per l'anteprima del documento

È possibile impostare fino a 4 browser richiamabili direttamente da 1st Page per la visualizzazione dei documenti in fase di editing.
L'impostazione è molto semplice e può essere eseguita nei seguenti modi:

· Dalla barra Easy: Preview->Edit Browser List
· Dalla barra Expert: View->View External Browser List->Edit Browser List; N.B.: Ricordo che la barra View non fa parte delle barre selezionabili tramite le linguette, ma si trova in alto a sinistra;

· Dal menu: [File->Preview in Browser->Edit Browser List]
· Ancora dal menu: [Options->General Program Preferences->Browsers Previewing]
A questo punto basta premere il tasto AUTOSEARCH per ritrovarsi i vari browser presenti sul sistema impostati automaticamente; in alternativa (o se non vengono riconosciuti), è possibile impostare sugli spazi a sinistra i nomi con cui si desidera vengano visualizzati i browser disponibili e sugli spazi a destra i percorsi degli stessi (col tasto a forma di cartellina aperta si ha ovviamente la possibilità di navigare fra le cartelle per identificare il programma.
Consiglio: In realtà nessuno ci obbliga ad impostare solo dei browser; può essere utile ad esempio per chi lavora con più programmi di editing, indicarli qui in modo da aprirli velocemente ed avere in contemporanea l'apertura della pagina su cui stiamo lavorando.

Richiamare i browser esterni

Per richiamare i browser si utilizzano gli stessi strumenti elencati prima (tranne quello che richiama il menu Options) e con la differenza che anziché selezionare come ultima voce quella "Browser list", si seleziona direttamente il nome del programma su cui si vuole avere il Preview.
Va sottolineato che è possibile andare in anteprima anche senza aver salvato il documento. Sempre a proposito di salvataggio vi ricordo che è possibile annullare le ultime modifiche anche dopo aver salvato (vedi). 

Possibilità offerte dalla modalità Anteprima interna al programma

Abbiamo già visto in precedenza la possibilità di impostare un'anteprima in tempo reale tramite suddivisione dello schermo in 2 parti di cui una destinata all'editing e l'altra all'anteprima.
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	· Andando invece in modalità Anteprima tramite il tasto PREVIEW posto in alto, ci si trova di fronte ad un piccolo browser interno al programma. Da qui sarà possibile ad esempio, dopo aver visualizzato un documento in anteprima, seguire i link per visualizzarne degli altri e poi tramite i tasti BACK e FORWARD, tornare al documento precedentemente visualizzato o andare al successivo. Seguono poi gli immancabili tasti STOP e REFRESH per bloccare il caricamento di una pagina o per rieffettuarlo. 

· Segue poi il tasto FONT, che consente di passare sequenzialmente per 5 diverse dimensioni dei caratteri, così come accade in Internet Explorer. Cito tale programma perché la modalità Anteprima di 1st Page utilizza proprio Internet Explorer.

· Il successivo tasto, PREVIEW RESOLUTION è forse il più interessante in quanto simula, all'interno della sola area di anteprima, diverse risoluzioni video, consentendo quindi di ottimizzare le pagine in base a diverse risoluzioni senza cambiare la risoluzione da Windows (il che la modificherebbe per tutto il sistema).

· Il tasto OPEN LOCAL/REMOTE DOCUMENT attiva/disattiva la visualizzazione di una barra degli indirizzi nella parte bassa della finestra di Anteprima, consentendo di digitare l'indirizzo di un documento che si vuole visualizzare. È possibile digitare un percorso locale o un indirizzo internet.

· Il tasto FULL SCREEN credo non abbia bisogno di spiegazioni: serve solo ad attivare/disattivare la SIDEBAR.

· Il tasto RULER ha una sua utilità per l'ottimizzazione della pagina alle varie risoluzioni (soprattutto in abbinamento ai tasti FONT e PREVIEW RESOLUTION) perché visualizza le dimensioni in pixel della pagina.

· Infine OPEN PAGE IN EXTERNAL BROWSER apre la pagina all'interno di Internet Explorer (se installato). 


Creare una tabella tramite wizard

Come ormai saprete wizard significa mago e sta ad indicare alcuni strumenti presenti nei programmi per facilitare la creazione di particolari elementi. In questo caso vediamo il wizard di creazione tabelle:

· Dalla barra Easy: Tables 

· Dalla barra Expert: Tables->Table Tag Editor 

· Dalla barra Hardcore: Tables->Table Builder 

· Dal menu: [Insert->Tables] 

· Le prime scelte che ci si presentano riguardano il numero di righe (ROWS) ed il numero di colonne (COLUMNS); modificando tale numero notiamo che in basso ci viene presentata un'anteprima della tabella col numero di celle selezionato.

· All'interno dello spazio bianco è possibile inserire del testo all'interno delle celle; per l'inserimento di immagini bisogna aspettare di essere usciti dal Wizard. Premendo ripetutamente il tasto TAB dallo spazio di inserimento testo si passa da una cella alla successiva in modo da poterle compilare tutte. La stessa operazione può essere fatta anche col mouse premendo sulla cella nella zona di anteprima.

· Su TABLE WIDTH (larghezza) e TABLE HEIGHT (altezza) è possibile indicare le dimensioni totali della tabella sia in pixel che in percentuale (nel secondo caso bisogna attivare la casella "%"). Ricordo a tal proposito che l'utilizzo di una tabella con dimensione 100% può aiutare notevolmente nell'impostazione di una pagina indipendentemente dalla risoluzione video di chi la visualizzerà (vedi corso HTML).

· Seguono i tasti CELLSPACING e CELLPADDING: il primo indica lo spazio tra una cella e l'altra (sia in orizzontale che in verticale), mentre il secondo indica lo spazio interno alle celle (in pratica il margine).

· Passiamo ora alla seconda sottoscheda dal titolo EXTENDED: 

· È possibile indicare un CAPTION, cioè una breve descrizione del contenuto della tabella; per poterlo inserire bisogna prima premere sulla casella TABLE CAPTION.

· Il CAPTION ALIGN permette sia di indicare l'allineamento orizzontale del CAPTION (left, right, center), sia di indicare se si vuole posizionare lo stesso in alto o in basso (TOP, BOTTOM).

· Abbiamo poi l'allineamento delle celle (CELL ALIGNMENT); tale impostazione influisce indistintamente su tutte le celle, ma ho notato che sulla versione 2 di 1st Page, non funziona;

· Passiamo alla dimensione del bordo che va indicato con un numero (0 è bordo inesistente); anche tale opzione agisce a livello globale;

· Il TABLE COLOR consente di indicare il colore di sfondo della tabella;
Consiglio: indicate il colore dello sfondo anche se indicate un'immagine di sfondo per compatibilità con chi non carica le immagini; altrimenti si può rischiare di ritrovarsi lo sfondo di un colore uguale o simile a quello del testo;

· BACKGROUND IMAGE consente invece di impostare un'immagine come sfondo della tabella;

· TABLE BORDER COLOR imposta il colore del bordo (per default nero);

· L'ultima opzione consente di indicare due colori diversi per i bordi (provate per capire il risultato che si ottiene);

· Attenzione al tasto CLEAR che elimina tutte le impostazioni effettuate ed i campi già compilati;

· Purtroppo una volta creata la tabella non è previsto il ritorno al wizard per eventuali modifiche, come accade invece con il wizard per l'inserimento immagini.

Inserimento rapido tabella

Un metodo rapido di inserimento tabella si trova sulla barra Expert:
Tables->Speedy Table Sizer (Quick Table Insertion); da qui basta spostarsi col mouse sulla griglia e premere quando si ha il numero desiderato di righe e colonne (massimo 5x5). In basso a sinistra si ha l'indicazione del numero correntemente selezionato. Se si cambia idea basta premere sulla X in basso a destra. Utilizzando questo metodo, si ha solo la creazione della tabella e delle relative celle; qualunque opzione andrà eventualmente inserita a mano. 

Altri tasti di inserimento rapido

Considerando che sulla barra Easy non ci sono altri strumenti, passiamo alla barra Expert:
Tables->Table Header inserisce un'intestazione;
Tables->Table Data inserisce una cella;
Tables->Insert Rows inserisce una riga;

Elementi della barra Hardcore

Dalla barra Hardcore invece c'è da segnalare che tutti i tasti presenti consentono l'inserimento di tag completi di tutte le opzioni possibili; basterà quindi compilare le opzioni desiderate all'interno delle doppie virgolette. Provate ad esempio ad inserire il tag TD: esso consentirà di indicare per la sola cella corrente l'allineamento orizzontale ALIGN e verticale VALIGN, le dimensioni, l'opzione NOWRAP per eliminare l'a capo automatico, il colore dello sfondo e del bordo e l'immagine di sfondo.
Inoltre sono presenti più opzioni rispetto a quelle del wizard che in realtà non è proprio completo.
Se ad esempio desideriamo suddividere la tabella fra intestazione THEAD, corpo TBODY e piede TFOOT, o inserire COLGROUP per specificare le caratteristiche di un gruppo di colonne, l'unico punto da cui è possibile inserirli è proprio la barra Expert. 

Creare un elenco puntato con un'immagine come elemento di puntatura

Per fare ciò va creata una tabella con 2 colonne e con numero di righe pari al numero di elementi dell'elenco. Nella prima colonna inseriremo l'immagine e nella seconda il testo dell'elenco. Nel caso il testo di un elemento superi lo spazio di una riga, bisogna fare attenzione al posizionamento verticale: la colonna con le immagini andrà centrata verticalmente in alto, per quella col testo è indifferente centrarla verticalmente in alto o al centro. 

Trasformare del testo in tabella

Dopo aver selezionato il testo, premere sul menu contestuale: Selected->Convert lines to table; si ottiene così una tabella in cui ogni riga corrisponde ad una riga del testo originale. Per riga si intende del testo separato da un ritorno a capo (con INVIO). Si potrà poi modificare la tabella a proprio piacimento. 

Incollare del testo e convertirlo in tabella

È un'opzione presente sul menu [Edit->Paste and convert to tables]; incolla del testo dagli appunti di Windows e lo converte in tabella. Anche in questo caso avremo una riga per ogni INVIO ed una sola colonna. 

Unire più celle in una unica

Tale operazione non è presente su nessun tasto di 1st Page ma per ottenere tale effetto basta inserire l'opzione ROWSPAN=n o COLSPAN=n dove n è il numero di celle successive da inglobare in quella presente. Tale opzione va inserita all'interno del comando TD. Utilizzando ROWSPAN si inglobano più righe in una e con COLSPAN si inglobano più colonne. Chiaramente se si vogliono dividere più celle unite basta eliminare tale opzione oppure diminuire il numero precedentemente indicato.

Cosa sono i frames

Una pagina con i frames è una pagina che fa "da contenitore" per altre pagine. In pratica nella pagina di partenza, vengono definiti dei collegamenti ad altre pagine e viene definito lo spazio e la posizione in cui queste devono essere visualizzate quando si chiede di visualizzare la pagina di partenza.

All'interno della pagina di partenza la definizione dei frames sostituisce il tag BODY e tutto il suo contenuto. Quindi tale pagina non avrà un suo contenuto ma solo delle indicazioni per il caricamento delle altre pagine. Le altre pagine invece sono delle pagine normalissime, che possono anche essere strutturate inizialmente per una visualizzazione a finestra intera. In ogni caso esse non contengono nessun comando relativo ai frames (amenoché non si vogliano fare dei frames nei frames!!).
Consiglio a chi non avesse ancora studiato un corso HTML, di vedere alcuni esempi sui frames. 

Inserimento di frames

Dopo questa premessa, passiamo a vedere quali strumenti offre 1st Page per la definizione dei Frames: 
Premesso che non ci sono richiami ai frames né sul menu, né sull'Easy bar, passiamo alla barra Expert ed a quella Hardcore:

In entrambi i casi le barre sono identificate col nome FRAMES, anche in questo caso i comandi inseriti tramite la barra Hardcore sono completi, mentre tramite Expert non vengono inserite tutte le opzioni, ma vediamoli con ordine:
Una volta creato un nuovo documento vuoto e senza il tag BODY, va inserito il FRAMESET: dalla barra Hardcore vengono inserite anche le opzioni relative al numero di righe e di colonne; qui andrà indicata la prima suddivisione da effettuare;

All'interno del tag FRAMESET vanno definiti i vari frames che si è deciso di creare (il numero deve coincidere col totale fra righe e colonne indicate in precedenza); anche in questo caso consiglio l'utilizzo della barra HARDCORE; andrà indicato obbligatoriamente il SRC, cioè il documento da caricare; le altre possibili opzioni sono: NAME che consente di identificare il frame con un nome univoco (vedremo dopo perché), FRAMEBORDER che consente di indicare il bordo con un numero da 0 a 10, le dimensioni dei margini; la presenza della scritta NORESIZE indica che il frame non potrà essere ridimensionato da chi lo visualizza andando a trascinarne il bordo; infine SCROLLING indica se è possibile visualizzare le barre di scorrimento (il valore auto indica che queste verranno caricate solo se il contenuto della pagina supera lo spazio visualizzabile).

Il comando NOFRAMES (uguale su entrambe le barre) non ha opzioni e serve per visualizzare qualcosa di alternativo per chi utilizza un browser che non supporta i frames. In genere si visualizza un testo di avvertimento ma si può anche inserire l'intero contenuto della pagina (il che però tende a rallentarne il caricamento) o reindirizzare l'utente su una pagina alternativa (consigliato).

Il comando BASE TARGET (presente solo su Expert), consente di indicare, oltre il percorso di base del sito (ad es. www.miosito.it) su HREF, utile quando si ha parte del documento online e parte offline, sia il frame su cui saranno caricate normalmente altre pagine richiamate da quelle presenti nei frame (su TARGET). 

Ad esempio posso suddividere la pagina in 2 frames: uno chiamato MENU e l'altro CONTENUTO (i nomi vanno indicati come già detto tramite l'opzione NAME di FRAME). Poi decido che il TARGET è CONTENUTO, così tramite il frame MENU in cui effettivamente caricherò una pagina contenente un menu di navigazione del sito, caricherò le varie pagine sul secondo frame chiamato CONTENUTO. 

I frames interni (IFRAME o Floating Frame)

Si tratta di un tipo particolare di frame che può essere posizionato in un punto interno di qualunque pagina e non è associato agli altri comandi visti finora. Viene utilizzato ad esempio per visualizzare dei piccoli testi o delle immagini richiamabili tramite link all'interno della pagina. Hanno delle similitudini rispetto al tag OBJECT con due sostanziali differenze: OBJECT è più vecchio e quindi maggiormente supportato e IFRAME, grazie all'opzione NAME, può visualizzare al suo interno pagine o file richiamati dal visitatore tramite la pagina principale.
Anche in questo caso il comando inserito tramite la barra Hardcore è molto più completo.

Le opzioni non presentano sostanziali novità rispetto a quelle già viste in altre occasioni, quindi le riassumo brevemente: SRC indica il nome del file da caricare (può trattarsi oltre che di un documento internet, anche di un'immagine o di qualsiasi file supportato dal browser internet; NAME consente di indicare un nome utile per richiamare tale frame come Target da un qualunque link presente sulla pagina principale; WIDTH e HEIGHT sono chiaramente la larghezza e l'altezza in pixel (si possono creare anche degli IFRAME piccolissimi); ALIGN indica l'allineamento orizzontale (il comando IFRAME fa iniziare il documento caricato su una nuova riga, ma per visualizzare un IFRAME a fianco ad altro testo o immagini, basta creare una tabella ed inserire l'IFRAME all'interno di una cella); FRAMEBORDER indica il bordo (come con i frames normali), seguono poi i margini e le opzioni per la barra di scorrimento.

I forms o moduli sono costituiti da un insieme di campi modulo che possono essere compilati dal visitatore per inviare delle informazioni. Visivamente possono essere simili ai campi modulo presenti nei programmi di inserimento dati e disponibili anche all'interno di programmi avanzati di videoscrittura, fogli elettronici ecc. Un modulo presente in una pagina HTML è caratterizzato da un primo tag, FORM, che indica il tipo di invio dei dati da effettuare e la loro destinazione. I dati stessi vengono generalmente spediti grazie all'utilizzo di un apposito programma CGI (Common Gateway Interface) che può essere presente direttamente all'interno del ns. sito o richiamato anche da un qualunque altro sito internet che ce lo mette a disposizione. 

Se non si dispone di un programma CGI, i dati possono anche essere spediti direttamente ad un indirizzo e-mail ma in questo caso essi avranno una formattazione piuttosto spartana. Ogni programma CGI può avere delle proprie caratteristiche e dettare delle proprie regole per quanto riguarda le possibili opzioni dei vari campi. Alcuni ad esempio consentono di specificare quali campi sono obbligatori, altri consentono anche di verificarne il corretto inserimento (ad esempio lunghezza minima e massima, presenza di caratteri alfabetici in alcune posizioni e numerici in altre, ecc.). Per maggiori informazioni su tali opzioni è necessario vedere la guida all'utilizzo del programma CGI che si utilizzerà. Per maggiori approfondimenti sui moduli, si può invece fare riferimento al corso HTML.

Inserimento dei campi form

Premettendo che né il menu normale, né quello contestuale, né la barra Easy contengono comandi sui form, passiamo alle altre 2 barre (Expert ed Hardcore) che sono invece piuttosto complete e che contengono ognuna una voce apposita. Anche in questo caso valgono le stesse osservazioni sulla maggior completezza delle opzioni inserite dalla barra Hardcore.
Inoltre i bottoni BUTTON, CHECKBOX, RADIO, IMAGE, BROWSE, PASSWORD, TEXT, HIDDEN TEXT, SUBMIT e RESET della barra Expert corrispondono all'unica opzione INPUT della barra Hardcore. Questo perché si tratta di diverse opzioni dell'unico tag INPUT.
Il bottone CHECKBOX della barra Expert restituisce erroneamente un codice RADIO. Inserendo il tag INPUT da Hardcore, viene inoltre erroneamente riportata l'opzione TEXTAREA che non è un'opzione di INPUT ma un tag a se stante (vedi invece barra Standard per il corretto inserimento).

FORM
Il primo, indispensabile comando che va utilizzato per la creazione di un modulo è FORM presente su entrambe le barre. Tutti gli altri comandi andranno inseriti al suo interno (cioè tra il comando <form> ed il </form>).
Inserendolo dalla barra Avanzata ci viene proposta la sola opzione ACTION che deve indicare il percorso dello script CGI o, in assenza di questo, direttamente l'indirizzo e-mail del destinatario dei dati. Inserendo il comando dalla barra Hardcore, possiamo notare altre opzioni tra cui METHOD che, se impostato su GET, limita il numero massimo di caratteri a 255 e li suddivide in due variabili, se impostato su POST, consente l'invio di un numero di caratteri illimitato.

SUBMIT e RESET semplici e tramite IMAGE
Gli altri elementi indispensabili sono i tasti SUBMIT e RESET che consentono il primo di spedire i dati ed il secondo di cancellarli senza effettuarne l'invio. Mentre sulla barra Expert sono disponibili direttamente i tasti già pronti, da quella Hardcore sarà necessario scegliere un generico comando INPUT in cui si sceglierà come TYPE il Submit o il Reset oltre ad altre opzioni che vedremo più avanti. Per modificare il testo che appare sul bottone basta inserirlo all'interno dell'opzione VALUE.
In alternativa si può anche usare un'immagine a cui abbinare i comandi SUBMIT e RESET, utilizzando sempre il tag INPUT, ma con TYPE="IMAGE". In tal caso andrà anche indicato il percorso dell'immagine in SRC e andrà utilizzato uno script per dare il comando di invio o di reset.

Opzioni generali
TITLE indica un testo aggiuntivo che su alcuni browser appare sotto forma di tooltip.
Ricordiamoci sempre l'importanza di impostare il campo NAME indispensabile per poter successivamente abbinare il nome del campo al suo contenuto (lavoro effettuato dallo script CGI). Il nome sarà utile inoltre se si vogliono inserire degli script di controllo correttezza dei dati (ad esempio in Javascript).
TABINDEX, se utilizzato, indica la sequenza dei campi premendo il tasto TAB. Va compilato con dei numeri da 1 in poi.
DISABLED rende il campo non attivo e READONLY non consente di effettuare modifiche. 

TEXT
L'opzione di utilizzo più immediato è TEXT che serve a creare una semplice casella per l'inserimento di testo. Si può impostare tramite VALUE un valore iniziale, ad esempio se va inserito il nome si può inserire la scritta "nome", ma in genere viene considerato più comodo per l'utente trovarsi lo spazio vuoto in modo da poter iniziare direttamente la digitazione senza dover prima cancellare il testo già presente. 
Tra le altre opzioni: SIZE consente di impostare la dimensione orizzontale della casella, MAXLENGTH indica il numero massimo di caratteri da accettare. 

TEXTAREA
Se il testo da richiedere all'utente può superare la singola riga, allora si ricorre al tag TEXTAREA che può essere dimensionato a piacere tramite indicazione del numero di righe ROWS e di colonne COLS visualizzabili. Il testo inserito dall'utente può però eccedere la parte visibile. Anche qui il campo VALUE può indicare un testo precompilato.

RADIO
RADIO permette di creare tramite dei pulsantini di tipo radio, più possibilità alternative (per cui selezionandone una, le altre si deselezionano in automatico). Tale risultato si ottiene creando più campi RADIO con lo stesso NAME e con diverso VALUE. L'opzione CHECKED indica quale bottoncino è già attivo.

CHECKBOX
CHECKBOX consente di inserire dei quadratini da selezionare o deselezionare; sono utilizzabili da soli per compilare dei campi di tipo vero/falso o in gruppo.
L'utilizzo di più campi CHECKBOX in gruppo è simile a quello dei campi RADIO: infatti va dato un unico NAME a tutti e diversi VALUE. Però in questo caso sono consentite scelte multiple. Qui l'opzione CHECKED può indicare come già contrassegnati uno o più campi (o nessuno se non viene utilizzato). 

SELECT e LISTBOX
I tasti FORM SELECT e FORM LISTBOX della barra Expert consentono, come preannunciato dal disegno presente sugli stessi bottoncini, di creare delle liste testuali di selezione in cui, nel primo caso possiamo fare una sola scelta, nel secondo più di una. Il tag che i due tasti richiamano è in realtà lo stesso ed è il tag SELECT, solo che nel secondo caso esso contiene anche l'opzione MULTIPLE. In entrambi i casi sarà necessario dare il NAME e indicare per ogni OPTION il VALUE (testo che apparirà), e l'eventuale scritta SELECTED su una o più opzioni che si desiderano attive al momento della visualizzazione.

OPTGROUP
Il tag OPTGROUP (all'interno di FORM SELECT e FORM LISTBOX) consente inoltre di formare dei gruppi di opzioni. Tale comando non ha effetto sul risultato visibile dall'utente ma può solo rendere più agevole da parte di chi crea la pagina, il raggruppamento di opzioni simili.
Passiamo ora alle opzioni un po' particolari del tag INPUT:

BUTTON
L'opzione BUTTON consente di creare un bottone (tipo quelli submit e reset) con un testo personalizzato (da indicare in VALUE). A tale bottone sarà possibile assegnare uno script.

FILE
L'opzione FILE (FORM BROWSE sulla barra Expert) crea un campo testo seguito da un tasto SFOGLIA e consente di inserire il percorso di un file presente sul nostro computer.

PASSWORD
L'opzione PASSWORD inserisce ancora un campo testo ma in questo caso durante la compilazione dello stesso la visualizzazione del testo effettivo sarà sostituita da degli asterischi. I dati verranno comunque mandati correttamente.

HIDDEN
Infine l'opzione HIDDEN consente di inserire dei campi da spedire che non verranno visualizzati dall'utente. A seconda del CGI utilizzato essi potranno essere diversi. Un utilizzo molto comune consiste nell'impostare l'oggetto dell'e-mail ed il destinatario con un comando di questo tipo:
<INPUT TYPE=HIDDEN NAME=MAILFORM_SUBJECT VALUE="Titolo del form">

FIELDSET - Organizzazione visiva dei dati
Il tag FIELDSET consente di organizzare visivamente più campi all'interno di un riquadro. Sarebbe poi opportuno inserire un tag LABEL al suo interno in modo da poter identificare l'insieme dei campi con un nome; ad esempio possiamo inserire i campi nome, cognome e codice fiscale all'interno di un Fieldset "Dati Anagrafici" e i campi telefono, fax, e-mail in un Fieldset dal nome "Recapiti".

LABEL
Il tag LABEL, oltre che nell'occasione appena vista, può essere utilizzato per scrivere il testo descrittivo dei vari campi e per impostare eventualmente un tasto di accesso rapido. Esso è presente solo nella barra Hardcore. Per associare un LABEL ad un campo della form basta indicare nell'opzione FOR del label il nome del campo; in alternativa il tag del campo può essere incorporato all'interno di quello del label.

Chi vuole crearsi una libreria di piccole funzioni utilizzando un linguaggio di scripting, stili CSS o qualunque altra risorsa riutilizzabile, può ricorrere in 1st Page a due strumenti diversi:

My Code
My Code è uno strumento presente sulla Side Bar e caratterizzato da un'icona a forma di matita. Dopo averlo richiamato, è possibile vedere immediatamente la lista di parti di codice già salvate e un'anteprima di quella che è correntemente selezionata. Premendo sulla matita in alto a sinistra o tramite menu contestuale: New, possiamo creare (o incollare dagli appunti) una nuova parte di codice che intendiamo salvare. Basterà inserire un nome identificativo ed il codice, che può essere separato tra codice iniziale e finale. 

Con un singolo click del mouse sul nome della funzione, sarà possibile vederne il contenuto in anteprima, mentre con un doppio click, essa verrà inserita nel punto di inserimento del documento ed il cursore lampeggerà tra la parte iniziale di codice e quella finale. Questo strumento può quindi essere utile per inserire tag HTML personalizzati (ad esempio per formattare i caratteri in un certo modo). Ma si può inserire qualunque testo, si può quindi usare anche come glossario contenente testi ripetitivi o qualunque altra cosa.

Ogni funzione inserita può essere rinominata, eliminata o modificata tramite menu contestuale (rispettivamente tramite le voci: RENAME, DELETE, EDIT e può anche essere esportata in un file di testo (Export to text file). In questo modo sarà possibile salvarsi le funzioni per installarle su un altro computer o sullo stesso dopo una reinstallazione del programma. Per fare ciò basterà creare una nuova voce e, dopo averle dato un nome, selezionare il tasto INSERT per scegliere il testo dal file.

Un'altra possibilità per creare una nuova voce consiste nel selezionare direttamente all'interno di un documento il testo che ci interessa e poi scegliere da menu contestuale: Selected->Add selected text to MyCode Library. 

Code Templates
Un altro strumento a disposizione è Code Templates. Questo secondo strumento, raggiungibile tramite menu: Options->Editing Preferences->Code Templates per l'inserimento di nuovo codice, è invece richiamabile direttamente tramite una sequenza rapida di tasti (se non lo avete modificato, tramite CTRL+J) per l'inserimento del codice all'interno di un documento.

L'inserimento di nuovo codice appare abbastanza immediato, una volta richiamata la voce apposita dal menu, basterà inserire un nome, una descrizione e, in basso, il codice; 
Attenzione: ricordatevi infine di premere sul tasto ADD perché se non lo fate e poi andate su OK, la finestra si chiude e perdete il codice appena inserito. Le altre opzioni disponibili sono DELETE (per eliminare una voce) e REPLACE che prende il posto di DELETE nel momento in cui vado a modificare una delle voci già inserite.

Per richiamare il codice ed inserirlo nel documento, basterà premere CTRL + J (tenendo premuto il tasto CTRL premere sul tasto J) e fare doppio click o INVIO sulla voce che ci interessa. 

Differenze fra i due strumenti
In effetti può apparire strano il fatto che ci siano strumenti abbastanza simili, comunque ognuno può scegliere quale ritiene più comodo da usare o se preferisce usarne uno per alcune cose e l'altro per altre. Il primo che abbiamo visto è più comodo per l'inserimento di nuovo codice, per la possibilità di salvarlo in un file esterno e in generale per la comodità della Side Bar che può essere sempre visibile o eventualmente può riapparire con un semplice click.

In 1st Page 2000, i CSS (Cascading Style Sheets o Fogli di Stile a Cascata) sono supportati in due modi:

· il codice CSS viene riconosciuto e visualizzato con un colore particolare (personalizzabile); 

· è possibile trasformare un normale documento in documento che supporti pienamente i CSS:
per fare questo andare sul menu: [Tools->Tidy HTML Quick Tools->Upgrade to StyleSheets]; il documento verrà convertito automaticamente sostituendo i tag di formattazione HTML con l'indicazione di stili e gli stili utilizzati saranno impostati all'inizio del documento. Per maggiori informazioni sull'uso di questo strumento, vedere il capitolo dedicato alle conversioni. 

Purtroppo però non è stato inserito uno strumento che consenta di creare velocemente degli stili, quindi questi dovranno essere creati completamente a mano, oppure usando altri programmi. Ci sono anche programmi specifici che hanno come unico scopo quello della creazione di CSS.

Inserire file audio

Considerando che Explorer e Netscape hanno deciso di usare comandi diversi per l'inserimento di una musica di sottofondo, in 1st Page è stato inserito un bottone sulla barra Expert [Advanced->Add Support to Play Sound/Music Files] che inserisce entrambi i comandi. Basta indicare il nome del file all'interno di SRC, su LOOP il numero di volte che si vuole venga eseguita la musica (0 o infinite per un play continuo). Tramite EMBED si può anche decidere se visualizzare i comandi per fermare o riprendere la musica (tramite HIDDEN=FALSE) e se far partire la musica al caricamento della pagina (AUTOSTART=TRUE). Con BGSOUND invece la musica parte da sola e l'utente non può interagire con i comandi. Consiglio di utilizzare EMBED, oltre che per maggior completezza, anche perché è supportato da un maggior numero di browser mentre BGSOUND è proprietario di Explorer.

Inserire file video

Si utilizza nuovamente EMBED, ma sulla barra standard è presente un tastino apposito che inserisce il comando già personalizzato per il video (quindi con le opzioni per impostare le dimensioni). 

Inserire animazioni in Flash

Premendo sull'apposito tasto della barra Standard, viene inserito tutto il codice necessario; come potete notare, anche in questo caso il comando è EMBED, ma sono presenti anche diversi altri comandi. Ricordatevi di sostituire il nome che appare dopo EMBED SRC con il nome e l'eventuale percorso della vostra animazione!! 

Inserire altri elementi

Dalla barra Standard è possibile richiamare il codice per l'inserimento di altri elementi multimediali come ActiveX, Client Pull, Shockwave, Layer DHTML.
Abbiamo inoltre un tasto che inserisce un generico comando EMBED e infine quello che gestisce le PAGE TRANSITIONS (richiamabile anche da menu: [Format->Page Transitions]). Quest'ultimo elemento è supportato solo da Explorer, quindi non sarebbe molto corretto utilizzarlo, comunque consente di creare degli effetti da abbinare ai seguenti eventi: ingresso nel sito, uscita dal sito, ingresso in una pagina, uscita da una pagina. Gli effetti possibili sono diversi: per chi è interessato non resta che provarli!

Il tag OBJECT

Lo trovate sulla barra Hardcore ed il suo uso è raccomandato dallo standard HTML 4 in sostituzione dei comandi di inserimento suoni, elementi multimediali ed applet Java.

Premessa sui JavaScript

Per chi non sa cosa sono, si tratta di programmini (che i programmatori chiamano script per differenziarli dai programmi creati con linguaggi di programmazione più complessi) che consentono di integrare direttamente all'interno delle pagine HTML alcune funzionalità aggiuntive (testo che scorre, orologio, banner a rotazione, ecc.). I JavaScript sono compatibili pressoché con tutti i browser e quindi non creano particolari difficoltà di compatibilità. È comunque una buona regola inserire sempre il codice alternativo NOSCRIPT per eventuali browser non abilitati. All'interno di tale tag andrà possibilmente inserito del codice HTML alternativo (quindi testo, immagini o altri elementi). C'è anche un tastino sulla barra Expert->Scripts->No Script. Essendo i JavaScript incorporati nelle pagine, non c'è bisogno di avere alcun permesso particolare sul server (come accade per i CGI o per pagine ASP e PHP). Essi vengono scaricati sul computer dell'utente insieme alla pagina da visualizzare e poi eseguiti. 

Utilizzare i JavaScript già pronti

1st Page, oltre ad essere un programma gratuito, viene fornito con più di 450 JavaScript già pronti all'uso, catalogati e commentati. È così possibile sbizzarrirsi sia se non si ha la pazienza di imparare il linguaggio, sia se si è a corto di fantasia, sia per utilizzarli come strumento didattico, sia infine per prendere spunto da alcuni di essi per poi migliorarli. 

Note sul Copyright

Per la questione del Copyright sarebbe bene chiedere un consiglio agli esperti che scrivono spesso articoli al riguardo proprio su questo sito, io posso solo dirvi che sulla finestra di scelta script c'è la seguente scritta: "EvrSoft Istantz Scripts © Copyright EvrSoft - All rights reserved". Prima di dare l'OK per l'inserimento dello script veniamo "incoraggiati" ad inserire un logo che indica che il nostro sito è stato "enchanted" (stregato) dalla tecnologia Iscript di EvrSoft. Comunque è più semplice non inserire il logo che inserirlo. Infine, dopo aver inserito uno script, all'inizio dello stesso appare come commento un invito a prelevare altri script gratuiti dal loro sito e l'eventuale indicazione del copyright dell'autore. 

Bottoncini di inserimento veloce JavaScript

Abbiamo già visto l'inserimento di un JavaScript: si tratta del RollOver Image (vedi). Facendo un giro sulla barra Expert Scripts, notiamo la presenza di altri script che possono essere inseriti con un solo click: si tratta di quelli che sono stati da loro considerati tra i più utili o i più richiesti e sono anche piuttosto brevi. Vediamoli:

JavaScript Open Window - Apertura di una finestra
Questo script, richiamabile tramite la barra Expert: Scripts->Javascript Open Window, permette non solo di aprire una nuova finestra del browser indicando la pagina da caricare, ma anche di definire per la stessa finestra tutta una serie di parametri: TITLE (per la sua utilità vedi TARGET), dimensioni in pixel, visualizzazione o meno dei seguenti elementi del browser:

· BROWSER NAVIGATION BAR: barra di navigazione (tasti avanti, indietro, ecc.); 

· MENUS: menu; 

· BROWSER SCROLLBARS: barre di scorrimento (un'unica opzione sia per la barra orizzontale che per quella verticale); 

· MAKE WINDOW RESIZEBLE: possibilità da parte dell'utente di ridimensionare la finestra (ingrandirla o rimpicciolirla); 

· LINKS BAR: barra dei collegamenti; 

· BROWSER STATUS BAR: barra di stato (la scritta posta solitamente nella parte bassa del browser); 

· LOCATION/URL BAR: barra degli indirizzi; 

· COPY HISTORY: visualizzazione della cronologia delle pagine già visitate; 

· RUN IN FULLSCREEN MODE: apertura della nuova finestra a pieno schermo; 

Messaggi di avviso e di conferma
Tramite il tasto Scripts->Javascript Alert Dialog viene creato lo script (di ben una riga) che mostra una finestrella con un avvertimento. Il tasto Scripts->Javascript Confirmation Dialog serve invece a mostrare una finestra di conferma (con i tasti SI e NO). In entrambi i casi il testo interno alle virgolette è personalizzabile. 

Inserimento testo
Il tasto Scripts->Javascript Write inserisce un comando per l'inserimento di testo all'interno della pagina. A chi non conosce gli script, questo comando può sembrare superfluo in quanto il testo nelle pagine si può inserire direttamente. Ma può essere utile in diversi casi: ad esempio per inserire variabili o risultati di calcoli (ad esempio, come vedremo più avanti, data e ora corrente, o data e ora dell'ultima modifica di un file); oppure può servire per creare una nuova pagina "al volo". 

Identificazione I.P.
Tramite il tasto Scripts->Javascript IP Detection si ottiene uno script che riconosce il numero I.P. ed il nome host del visitatore e lo visualizza all'interno della pagina. Quindi ogni visitatore vedrà il proprio numero I.P.

JavaScript Wizard
Sempre sulla barra Expert, abbiamo il tasto Scripts->Javascript Wizard che permette la creazione veloce di alcuni JavaScript:

FRAME KILLER
Da usare solo se il nostro sito non ha frames: serve per forzare il caricamento della nostra pagina sull'intera finestra eliminando eventuali frames (a volte le pagine che contengono link ad altri siti usano caricare questi ultimi all'interno di un frame). Anche questo script non presenta particolari complessità. Andiamo ad esaminarlo: 
SetTimeOut consente di eseguire un certo comando ad una certa distanza di tempo dal caricamento della pagina. In questo caso il comando impostato è "changePage()" che è il nome della funzione scritta subito dopo ed il tempo di attesa è impostato a 3000 millisecondi (quindi 3 secondi). La funzione ChangePage infine, controlla se ci sono frames e in caso affermativo, ricarica la pagina a schermo intero. "document.location" indica l'indirizzo della pagina corrente (in caso di frames indica l'indirizzo del frame corrente) e "self.parent.location" indica l'indirizzo del "genitore" della pagina caricata nel frame corrente. 

BROWSER TYPE
Tramite il comando "document.write" già visto su, consente di scrivere una frase definita da noi, seguita da "navigation.appName" (nome del browser in uso) e da "navigation.appVersion" (versione dello stesso). 

CURRENT URL
Inserisce l'indirizzo della pagina correntemente visualizzata. Per quanto riguarda il codice provate a vedere voi stessi: se avete seguito bene fin qui, non c'è niente di nuovo. 

LAST MODIFIED DATE
Molto utile: scrive la data di ultima modifica della pagina corrente. Così il visitatore sa subito se può aspettarsi qualche novità dall'ultima visita. 

DOCUMENT FADER
Crea un effetto di transizione dello sfondo da un colore ad un altro al caricamento della pagina. Basta impostare il colore di partenza, quello di arrivo e la velocità di transizione. 

DROP DOWN MENU
Creazione guidata di un menu a tendina per richiamare diverse pagine (o siti). Basta impostare in alto il nome della prima voce (ad es. "Scegli") sulla sinistra il nome da assegnare alle varie voci e sulla destra le url di destinazione.
In questo caso faccio notare ai meno esperti l'utilizzo del bottone all'interno di un form con un'azione associata all'evento ONCLICK: 

document.write('');

In pratica quando si preme sul bottone, viene richiamata la funzione di nome "go()".

Aggiunta ai preferiti di Internet Explorer
Lo script in questione è richiamabile tramite menu:
[Scripting->Force IE Bookmarks]
Ricordatevi chiaramente di sostituire l'url ed il titolo con quelli del vostro sito. 

Sbizzarrirsi con più di 450 scripts

La libreria di JavaScript che 1st Page mette a disposizione è raggiungibile nei seguenti modi:

1. barra easy: Scripts->Istantz Scripts; 

2. menu: [Scripting->Istantz Scripts]. 

A questo punto... non resta che sbizzarrirsi!!! 

Strumenti di creazione JavaScript

Per chi volesse creare i propri JavaScript da zero, sono disponibili alcuni strumenti: il primo lo si trova su:

· Easy: Scripts->Define Script Language; 

· Experts: Scripts->Define JavaScript; 

· menu: [Scripting->Define Script Language]; 

Da qui sarà possibile definire il linguaggio (come vedete ce ne sono diversi) ed in caso di JavaScript anche la versione (se non viene indicata si assume come buona la più vecchia e quindi ci si aspetta maggior compatibilità); il tipo di script (anche qui in base al linguaggio) e poi si può scegliere o di richiamare uno script esterno (in caso di JavaScript può essere salvato come file esterno con estensione .js), oppure dopo aver premuto su SCRIPT CONTENT, è possibile inserire lo script direttamente da questa finestra (non è indispensabile inserirlo da qui chiaramente).
Il secondo utile strumento si chiama Script Object Tree e mostra una lista completa di tutti i comandi JavaScript e di tutti gli eventi a cui si possono abbinare dei comandi (tra cui avvio di una funzione in qualunque linguaggio supportato, di un'applet Java, esecuzione di un suono, e qualunque altra cosa). Si chiama Tree (albero) perché è ordinato in livelli e sottolivelli in modo da facilitare la ricerca e anche la memorizzazione di qualsiasi elemento. Può essere posizionato e ridimensionato a piacere e rimane sempre visibile (finché non si chiude). Può essere richiamato così:

· menu: [Scripting->Script Object Tree]; 

· Expert: Scripts->Script Object Tree; 

Chiaramente un doppio click su un elemento della lista ne causa l'inserimento sul documento.
Inoltre possono tornare utili alcuni dei bottoncini visti in precedenza.

Inserire script DHTML già pronti

1st Page mette a disposizione anche alcuni script DHTML. Sono un po' nascosti ma ci sono. Sono raggiungibili tramite:

· Easy: Extras->DHTML Zone; 

· menu: [Insert->DHTML Zone]; 

Si tratta di soli 14 script ma sono di grande effetto. Premesso che sono compatibili con Explorer e Netscape entrambi a partire dalla versione 4 (per quanto riguarda gli altri browser non so), sarebbe opportuno prevedere qualcosa di sostitutivo per chi ha un browser che non supporta DHTML. 

Inserimento di Applet Java

Tramite:

· Easy: Extras->Java Applet; 

· Expert: Scripts->Java Applet; 

· Hardcore: JavaScript->Java Applet Tag Editor; 

· menu: [Insert->Java Applet]; 

è possibile, oltre che inserire un'applet Java, effettuare tutta una serie di impostazioni dello stesso come ad esempio dimensioni ed allineamento ed impostazioni aggiuntive (con l'avvertenza che alcune sono supportate solo da certi browser).

Per chi avesse intenzione di scrivere un'applet Java dall'interno di 1st Page, vorrei far notare che dal menu: [Options->Parser->Java] è possibile impostare il parser in modo che riconosca e evidenzi i vari elementi (comandi, variabili ecc.) di Java. Per modificare le opzioni del parser, vedere qui.

ASP e SSI

A questi due metodi di programmazione dal lato server sono state riservate 2 barre strumenti apposite sia su Expert che su Hardcore. Per quanto riguarda ASP non ci sono molte funzionalità (anche perché ASP più che avere comandi suoi, utilizza quelli di altri linguaggi), mentre i comandi SSI raggiungibili dalla barra Hardcore sono in numero maggiore.
Da notare il tastino che richiama una lista di variabili presente sia per ASP che per SSI sulla barra Expert. 

PHP

Per quanto riguarda PHP purtroppo non ho da aggiungere niente di nuovo. L'inserimento di pagine PHP può essere facilitato dal tool di definizione Script e dal Script Object Tree almeno per quanto riguarda la lista degli eventi che mette a disposizione. 

Cold Fusion e Web TV

Il team di sviluppo di 1st Page ha pensato anche a coloro che sviluppano applicazioni in ambiente Cold Fusion e in ambiente Web TV creando per loro delle apposite sezioni della barra strumenti Hardcore. Esse mettono a disposizione una lista molto dettagliata di comandi disponibili in questi due linguaggi.

Editor TXT, PL-SQL, Perl

1st Page può essere usato anche come editor TXT, PL-SQL e Perl (oltre che come editor Java e CSS come già visto). Per fare questo basta creare un nuovo documento vuoto e impostare il Parser sul menu: Options->Parser, in base al linguaggio che si intende usare. Il Parser riconoscerà tutte le parole chiave del linguaggio prescelto e le evidenzierà con un colore diverso. Impostando il Parser su testo normale, non verrà evidenziato niente.

Modificare l'impostazione dei colori per i vari parser

Le opzioni di attribuzione colori possono essere modificate tramite: Options->Editing Preferences. Qui sarà visibile l'attuale impostazione del parser con un'anteprima nella parte bassa dello schermo e si potranno fare le modifiche che si preferiscono per ciò che riguarda il Parser attualmente in uso. Per modificare le impostazioni del parser di un altro linguaggio bisognerà prima impostare il parser sul linguaggio desiderato e poi andando a vedere le Editing Preferences, si avrà la possibilità di visionare e di agire sulla situazione che lo riguarda.

Esempi Perl, Hts, CGI

Alla voce Scripting del menu, le ultime tre opzioni richiamano una lista di esempi di programmi e di script pronti all'uso. 
Quelli CGI sono scritti in C++. Non resta che dare uno sguardo al menu per scoprire cosa ci offre. Tra le opzioni in Perl abbiamo molte possibilità tra contatori testuali e grafici, validatori di carte di credito, visualizzatori di banner a rotazione, generatori random di testo e di links, semplici motori di ricerca, guestbook (libro degli ospiti), ecc.
Insomma chi ha intenzione di studiarsi tale linguaggio ha una buona documentazione pratica su cui cimentarsi.

Utilità di conversione pagine

Può capitare di aver fatto esperimenti con editor visuali che hanno dato come risultato del codice poco pulito o tag ripetuti o altri problemi. Inoltre ci si può trovare con alcuni tags in maiuscolo ed altri in minuscolo o ancora si può voler convertire un documento in formato testo. Per fare queste ed altre operazioni, ci vengono incontro diversi strumenti di 1st Page. Per le conversioni maiuscolo/minuscolo di qualunque porzione di testo e per decidere se i prossimi tag che inseriremo dovranno essere maiuscoli o minuscoli, vedere i capitoli precedenti.

Convertire un file di testo in HTML

Per ottenere tale risultato basta richiamare l'apposita voce sul menu: File->Convert Text File->HTML Document. Ci verrà chiesto di selezionare un documento da convertire e otterremo una copia di tale documento con formattazione HTML di base. In particolare avremo i tag indispensabili di una pagina web, quindi HTML, HEAD, BODY (con impostazione dei colori di base), TITLE e i vari BR che sostituiscono i vari INVIO. A questo punto sarà sufficiente sostituire la scritta "Untitled" che compare nel titolo con il titolo effettivo e salvare il documento. 

Inserire un file di testo in un documento

Se abbiamo un file di testo da aggiungere ad un documento già esistente, possiamo farlo tramite: File->Import/Insert Text File. In questo caso il file viene inserito così come è. Potremo poi procedere ad inserire i BR, convertire in liste o in tabelle tramite i semplici strumenti del menu contestuale alla voce Selected (vedi). 

Convertire un documento HTML in file di testo

Tale operazione è molto semplice: basta selezionare Tools->Strip All Tags e rispondere SI alla domanda successiva.
ATTENZIONE: In questo caso non viene creato un nuovo documento ma modificato quello attuale, quindi se volete salvare una copia del lavoro di formattazione HTML già fatto, evitate di premere il tasto SALVA ma andate su File->Save As e date un nuovo nome (o lo stesso nome ma con estensione TXT o comunque diversa). In caso di panico ricordatevi che, se l'opzione è stata precedentemente impostata (vedi), si può effettuare un UNDO anche dopo aver salvato. 

Gli strumenti di Tidy HTML

Tidy HTML è uno strumento creato da Dave Raggett per il consorzio W3C e messo a disposizione gratuitamente. Quelli di 1st Page lo hanno quindi potuto integrare all'interno del proprio editor aggiungendo anche un'interfaccia per il settaggio delle varie opzioni e rendendone alcune raggiungibili in maniera autonoma dalle altre. Cominciamo quindi col vedere le opzioni singole, premettendo che su ognuna di queste agisce l'opzione del menu: Tools->Tidy HTML Quick Tools->Output tags in uppercase che può essere attivato per ottenere nel risultato tutti i tags in maiuscolo o disattivato per averli tutti in minuscolo:

Applica formattazione del sorgente
Questa opzione, raggiungibile tramite: Tools->Tidy HTML Quick Tools->Apply Source Formatting, si propone di "formattare" il codice della pagina. Esso restituisce principalmente due risultati: 

· Sostituisce i caratteri speciali digitati dalla tastiera con i propri corrispondenti per il web; 

· Inserisce dei rientri gerarchici dei tag, mettendo anche su una nuova riga i tag di chiusura dei paragrafi. 

Va notato che queste due operazioni vengono eseguite anche dagli altri strumenti, in aggiunta alle altre che andrò ad elencare. 

Aggiorna il documento ai fogli di stile
Questo strumento (Tools->Tidy HTML Quick Tools->Upgrade to StyleSheets) è utile per chi si ritrova ad avere documenti HTML senza formattazione CSS e vuole applicare le modifiche del caso. Esso sostituisce le formattazioni di testo ricorrenti con l'applicazione di stili e definisce gli stili stessi all'inizio del documento (Inline Styles). Se poi si vuole creare un Foglio di Stile esterno, basterà spostare la definizione in un altro file e inserire il collegamento allo stesso all'inizio del documento. 

Conversione in formato XML
Tools->Tidy HTML Quick Tools->Convert to XML; in questo caso la conversione è in formato XML. 

Strumento Tidy HTML completo

Si avvia da: Tools->Tidy HTML Format and Fix. Appena avviato, ci si presenta una finestra in cui inizialmente compaiono alcune informazioni in inglese riguardo Tidy (che significa "mettere in ordine") che si possono riassumere brevemente con ciò che ho scritto all'inizio di questo capitolo. Lo scopo principale dello strumento consiste nel riordinare visivamente la pagina in modo da renderla più "presentabile" quando visualizzata in formato sorgente. C'è poi un tasto che richiama il sito web in cui trovare maggiori informazioni e sotto abbiamo a disposizione gli strumenti per: riportare le impostazioni iniziali (RESTORE DEFAULT SETTINGS), salvare le impostazioni correnti (SAVE SETTINGS) o richiamare impostazioni precedentemente salvate (LOAD SETTINGS).
Ma andiamo a vedere cosa può fare questo strumento:

MARKUP
Corrisponde a Applica formattazione del sorgente. 

WRAP
Inserisce un INVIO dopo il numero di caratteri impostati. Ne sconsiglierei l'utilizzo se non proprio indispensabile. Per la pagina da pubblicare significherebbe soprattutto maggior pesantezza. Infatti i browser web hanno l'a capo automatico e anche la maggior parte degli editor lo hanno. Per evitare che vengano inseriti INVII indesiderati consiglio di impostare il numero più alto possibile (9.999.999.999.999). 

TAB SIZE
Qui va impostato il numero di spazi a cui si vuole che corrisponda un carattere di tabulazione. Questo perché, se sono presenti dei caratteri TAB, essi verranno sostituiti con il numero di spazi qui indicato. 

INDENT
Se impostato su YES, vengono impostati dei rientri. In particolare avremo le sezioni del documento HEAD e BODY con un rientro, tutti gli altri elementi che indicano l'inizio e la fine di un paragrafo con due rientri e la prima riga di ogni paragrafo ugualmente con due rientri. Impostandolo su AUTO dice che dovrebbe "decidere" il programma quando è il caso o meno di impostare dei rientri, ma in base alle prove da me effettuate non ho riscontrato differenze rispetto al settaggio di YES. Con NO chiaramente non c'è nessun rientro ed eventuali rientri impostati precedentemente per i TAG vengono eliminati. 

INDENT SPACES
Se la precedente opzione non è impostata su NO, è da qui che si decide a quanti spazi deve corrispondere ogni rientro. 

INDENT ATTRIBUTES
Se attivato, inserisce un INVIO dopo ogni attributo. Ad esempio il tag: 
<body bgcolor="#666666" text="#CCFF66" link="#CC0033"> 
diverrebbe:
<body 
bgcolor="#666666"
text="#CCFF66"
link="#CC0033">
... a voi la scelta. 

HIDE ENDTAGS
Se attivato, provvede ad eliminare i tag finali non obbligatori come per esempio quelli di fine elemento di un elenco puntato. 

INPUT XML
Se il documento da processare è in formato XML, va indicato qui in modo che possa essere riconosciuto correttamente.

OUTPUT XML
Se attiva questa opzione converte il documento in formato XML.

ADD XML PI
Opzione valida solo se si vuole ottenere un documento XML. Se il documento di origine è già in formato XML PI (Processing Instruction), tale opzione non influenza il risultato. Diversamente, se attiva, l'output XML conterrà anche PI. 

OUTPUT XHTML
Se attiva, questa opzione da in output un documento XHTML. Se una o più opzioni XHTML sono già impostate nel documento di origine, esse vengono verificate ed eventualmente corrette. Inoltre i tags resteranno nel formato (maiuscolo o minuscolo) originale indipendentemente da come sono settate le altre opzioni. 

DOCTYPE
Non può essere modificato. 

CHARACTER ENCODING
Qui si imposta il formato e la dimensione della tabella codici da utilizzare. ASCII è quella di default e se non sapete cosa fare vi consiglio di lasciare tutto così. Considerando che su alcuni computer vengono riconosciuti solo 127 caratteri, alcuni formati convertono tutti i successivi, altri solo alcuni. Impostando ASCII si ha una maggior compatibilità perché tutti i caratteri oltre il 127° della tavola dei caratteri vengono trasformati. Impostando LATIN vengono trasformati solo quelli che eccedono il 255° carattere. UTF8 dà risultati piuttosto strani e ISO2022 converte pochissimi caratteri. 
P.S.: Per chi non sapesse cosa è una tavola dei caratteri, si tratta di una sorta di mappa su cui sono stati inseriti i caratteri che normalmente digitiamo da tastiera o che inseriamo come simboli o caratteri speciali e ognuno di essi, quando inserito sul computer, viene trasformato con un codice macchina. Il codice ASCII è il più universale, se così si può dire. In Italia, come anche negli altri paesi usiamo più di 127 caratteri, ma i primi 127 sono universalmente compatibili mentre i successivi sono personalizzati a seconda delle nazioni. 

NUMERIC ENTITIES
Trasforma i caratteri di cui ho appena parlato in un codice numerico anziché alfanumerico. Questa operazione li rende ancora più compatibili. 

QUOTE MARKS
Trasforma i caratteri di virgolette semplici e doppie nel corrispondente codificato. Consigliato attivarlo. 

QUOTE NBSP
NBSP cioè Non Breaking Spaces sono gli spazi indivisibili. Attivando questa opzione anche loro vengono convertiti. 

QUOTE AMPERSAND
FIX BACKSLASH

Se attiva questa opzione converte eventuali caratteri BACKSLASH (\) presenti in percorsi di file in SLASH (/) visto che gli utenti Windows usano la prima, ma su internet si usa la seconda e quindi un percorso indicato utilizzando la prima non verrebbe trovato su internet. 

WRAP SCRIPT LITERALS
Se attivo, attiva l'a capo all'interno di stringhe di testo particolarmente lunghe e lo fa precedere da un carattere BACKSLASH (\). 

WRAP ASP
Se attivo va a capo anche all'interno di comandi ASP. 

BREAK BEFORE BR
Se attivo, viene inserito un INVIO prima di ogni tag BR. Io personalmente preferisco l'INVIO dopo il BR, questione di gusti! 

UPPERCASE TAGS
Converte in maiuscolo tutti i TAGS. Per TAG si intende un comando HTML, ad esempio all'interno di: <BODY bgcolor="#666666" text="#CCFF66" link="#CC0033">, solo la parola BODY viene convertita in maiuscolo. 

UPPERCASE ATTRIBUTES
In questo caso vengono convertiti in maiuscolo gli attributi, quindi avremo come risultato: <body BGCOLOR="#666666" TEXT="#CCFF66" LINK="#CC0033">. 

CLEAN AND CONVERT DOCUMENT TO CSS
Se attivo corrisponde all'opzione UPGRADE TO STYLESHEETS vista più su. 

DROP FONT TAGS
Ha significato solo se è attiva l'opzione precedente. Se attivato, elimina diversi TAG di formattazione anziché sostituirli con i fogli di stile. I TAG in questione sono quelli relativi ai font ed ai paragrafi centrati tramite CENTER.
Attenzione: se questa opzione è attiva, si perde parte della formattazione. Avviando lo strumento singolo UPGRADE TO STYLESHEETS l'opzione è disattivata. 

Compressione del codice

Sul menu: Tools->HTML Source Compressor, troviamo un altro utile strumento di ottimizzazione codice. Mentre lo strumento appena visto ha essenzialmente il compito di "abbellire" il codice per facilitarne la lettura, oltre chiaramente ad una serie di altre utili funzioni, quest'ultimo strumento ha invece quasi la funzione opposta, cioè: rendere il codice più difficile da leggere (per rendere più difficoltosa l'eventuale copia dello stesso) e, soprattutto, ottenere delle pagine più leggere in termini di bytes occupati in modo che possano essere caricate più velocemente.
Questo strumento, a differenza del precedente, non opera sul documento correntemente aperto, ma richiede il nome del documento su cui operare e il nome del nuovo documento (che eventualmente possono anche coincidere). 
Attenzione però: fate in modo di avere sempre una copia del documento prima di procedere con questa operazione, oppure specificate un file di destinazione diverso da quello di origine. Questo perché sarà molto difficile operare delle modifiche sul file che si ottiene. Ripeto che lo scopo principale consiste nel creare una copia del documento più leggera possibile (e più difficile possibile da leggere in formato sorgente) da destinare alla pubblicazione su web. Ma se dovremo fare delle modifiche alle pagine, sarà sicuramente molto più agevole farle sul file originale.
Passiamo ora a vedere quali modifiche subiscono i file processati da questo strumento:

· Replace simple tags: sostituisce alcuni tag con altri che producono lo stesso risultato pur risultando più brevi. Dall'esempio presente nel programma stesso, si nota ad esempio che un tag STRONG viene sostituito con B. Il fatto che il secondo sia più breve è innegabile, bisogna però fare attenzione al fatto che mentre il primo è un tag logico, il secondo è fisico. Se quindi si fa uso di fogli di stile, si potrà decidere che il tag STRONG, che dovrebbe identificare del testo in evidenza, anziché corrispondere ad un testo in grassetto (B) corrisponde ad esempio a del testo in rosso. In tal caso va chiaramente disattivata l'opzione di conversione. 

· Put tag Center instead of P align=center: per quanto riguarda questa sostituzione non ho avvertenze particolari, anche perché secondo il W3C, CENTER è addirittura supportato leggermente meglio. 

· Remove superflous inverted commas in tags: elimina eventuali virgolette (singole o doppie) inutili all'interno di tags. Le virgolette sono indispensabili solo quanto si deve indicare più di una parola. Quindi è bene eliminare quelle inutili. 

· Remove superflous spaces: mentre con il Tidy HTML possiamo decidere di aggiungere degli spazi in modo da incolonnare i vari tags per ottenere un risultato più ordinato, adesso possiamo eliminare tutti gli spazi superflui. 

· Remove superflous returns: In HTML gli INVIO non danno nessun risultato, infatti per poter andare a capo bisogna inserire il tag BR o creare nuovi paragrafi. Di conseguenza ogni INVIO che abbiamo digitato per abitudine o per comodità, può essere tranquillamente rimosso. 

· Remove all returns: elimina assolutamente tutti gli INVIO creando di fatto un documento di una sola riga lunghissima. 

· Remove FrontPage's WEBBOT SPAN tags: elimina il tag WEBBOT SPAN creato da FrontPage. 

Ora non resta che dare OK per ottenere la compressione immediata in base alle impostazioni e la visualizzazione della finestra dei risultati: da qui potremo verificare il numero di bytes iniziali e quelli dopo la compressione, il numero di righe prima e dopo, vedere un'anteprima (sempre di prima e dopo) e decidere se si vuole aprire il documento compresso nell'editor.
Consiglio di fare l'operazione di compressione solo dopo aver completato il sito appena prima della sua pubblicazione e di creare una copia della cartella che contiene il sito prima di procedere con la compressione.

Download e installazione di 1st Transfer

Si tratta di un programma di gestione FTP molto semplice integrato direttamente in 1st Page. Nel momento in cui si installa 1st Page, quasi sicuramente 1st Transfer non risulterà installato; di conseguenza tentando di richiamare il programma si riceverà un invito a scaricarlo dal sito EvrSoft; ma l'indirizzo a cui si viene invitati ad andare (parlo sempre della versione 2.0 del programma) risulta errato, l'indirizzo di download corretto risulta essere: Download 1st Transfer.
Avvio di 1st Transfer

A questo punto il programma sarà richiamabile sia esternamente che dall'interno di 1st Page. Il collegamento per il richiamo diretto del programma non viene creato durante l'installazione, sarà quindi necessario localizzare il programma che si chiama transfer.exe e dovrebbe trovarsi nella stessa directory di 1st Page e creare il collegamento.
Per l'avvio dall'interno di 1st Page invece, abbiamo diverse possibilità:

· dalla barra Easy: Upload 

· dal menu: Tools->1st Transfer FTP 

· dal menu: File->Save to FTP (che non mi risulta funzionante) 

Presentazione del programma

Dopo aver avviato il programma, ci si ritrova in una schermata suddivisa in 3 parti: 

	1. a sinistra abbiamo un FILE EXPLORER che visualizza il contenuto del nostro computer; da qui premendo il tastino in alto a sinistra Browse, è possibile posizionarci nella cartella che preferiamo, oppure tramite il tastino sulla destra Up one level, salire di una cartella. 
	[image: image10.png]Full integration with the 1st Page™ family of products.
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	  a destra inizialmente non appare niente; dopo aver creato uno o più indirizzi di server tramite menu contestuale, apparirà la loro lista e, effettuando una connessione ad uno di essi, apparirà la lista dei file remoti. 
	

	  in basso appare invece il log della connessione, cioè la lista di comandi generati dal programma in base alle nostre richieste e le risposte del server. In questo modo è possibile tenere la situazione sotto controllo, visualizzare il messaggio di benvenuto sul server, e nel caso di errori, vedere di che errori si tratta. 


Impostazione di un server FTP
Come già accennato bisogna posizionarsi sul lato destro e premere col tasto destro per far comparire il menu contestuale da cui scegliere: Create Server.
Nella schermata che appare vanno inseriti i seguenti dati:

· SITE LABEL: è un nome mnemonico da assegnare per ricordarci di che sito si tratta. Tale nome apparirà poi come identificativo nella lista dei siti. Il nome sarà comunque facilmente modificabile. 

· SERVER: va indicato l'indirizzo FTP del server di partenza (in genere senza indicare eventuali subdirectory. 

· PORT: è già impostata su 21 e in genere si lascia così. 

· USER ID e PASSWORD: se non si tratta di un sito ad accesso pubblico vanno indicati, diversamente barrate l'opzione ANONYMOUS LOGIN in basso. Avrete anche notato che sopra ANONYMOUS LOGIN c'è l'opzione SAVE PASSWORD che evita di richiedere la password ad ogni connessione. 

· ACCOUNT: anche questo va indicato se il sito non è ad accesso pubblico ed anonimo; potrebbe corrispondere allo USER ID oppure nel caso di spazio ftp gratuito messo a disposizione insieme all'accesso ad internet, potrebbe corrispondere allo user id utilizzato per effettuare la connessione. 

· E-MAIL ADDRESS: attivando il login anonimo viene attivata tale casella perché alcuni server ad accesso anonimo chiedono come identificativo almeno l'indirizzo di posta elettronica. Quindi potrebbe essere necessario compilarlo (non necessariamente col nostro vero indirizzo). 

· INITIAL REMOTE DIRECTORY: abbiamo infine la possibilità di indicare la directory iniziale di visualizzazione; per quanto riguarda quella remota è indispensabile inserirla se dobbiamo accedere ad un indirizzo che non sia di 2° livello (ftp.indirizzo.it). Se quindi abbiamo a disposizione uno spazio gratuito su un sito, ci viene quasi sicuramente assegnata una sottodirectory ed abbiamo accesso solo a quella. 

· INITIAL LOCAL DIRECTORY: Per quanto riguarda la directory iniziale locale, può essere comodo far partire la visualizzazione dalla cartella che contiene i files da trasferire (o che conterrà quelli da scaricare dal server ftp). 

Infine, premendo in alto sul tasto INFORMATION, è possibile inserire del testo a nostro piacimento.

Collegamento al server
A questo punto possiamo dare OK e collegarci al server con un doppio click sull'icona che lo identifica.
Sulla parte destra dello schermo dovrebbe apparire il contenuto del sito; in basso possiamo osservare le varie fasi del collegamento e quindi se qualcosa non va, possiamo capire dove sta il problema.
Il collegamento (che sia andato a buon fine o meno) può essere annullato tramite Commands->Disconnect (presente anche sotto forma di icona in alto a destra Disconnect from server). Con Commands->Stop Transfer (o icona Stop Current Transfer) si blocca il trasferimento di dati senza disconnettersi dal server e con Commands->Connect (indovinate un po?) ci si riconnette. 

Trasferimento di files
Il trasferimento di files avviene con semplice operazione di trascinamento, oppure tramite i tasti a forma di freccia, posti al centro della schermata (Upload per caricare files dal ns. pc a quello remoto, Download per l'operazione inversa).

Operazioni effettuabili
È possibile ridimensionare le 3 finestre a nostro piacimento.
Possiamo poi, tramite menu contestuale, eliminare uno o più files (Delete o anche tramite il tasto CANC o DEL), creare una nuova cartella (Create folder), modificare il tipo di visualizzazione tramite Views (dimensione delle icone e presenza o meno dei dettagli).
Infine, il menu contestuale che appare premendo su un file, ci consente anche di visualizzarlo (con View) o di editarlo all'interno di 1st Page (Open in 1st Page). 

Attributi dei files
Il menu contestuale contiene anche altre 2 comandi: uno è Change file attributes (CHMOD) che consente di modificare gli attributi del file. Qui ci ritroviamo di fronte a delle opzioni diverse rispetto a quelle solite di Windows (che ci presenta 4 opzioni: SOLA LETTURA, ARCHIVIO, SISTEMA, NASCOSTO). Qui le opzioni sono 3: permesso di lettura (READ), di scrittura (WRITE) e di esecuzione (EXECUTE). Segnare la sola opzione READ corrisponde all'opzione SOLA LETTURA di Windows. Segnare anche WRITE corrisponde a togliere l'attributo di SOLA LETTURA di Windows ed infine l'opzione EXECUTE va impostata su tutti i file eseguibili (programmi).
Le stesse opzioni possono essere impostate per 3 livelli di utenti: il primo è il proprietario OWNER (cioè solo noi), il secondo è un gruppo al quale appartiene il proprietario GROUP, ed il terzo corrisponde a qualunque utente PUBLIC. A qualcuno queste opzioni possono apparire un po' strane, ma sono le opzioni utilizzate dai sistemi UNIX (quindi anche Linux). Credo che l'opzione più strana da comprendere per un utente Windows sia quella del gruppo: sui sistemi Unix, ma anche su quelli Windows Nt, si possono formare dei gruppi che hanno dei permessi particolari per l'accesso ad alcuni file (ad esempio il gruppo magazzino avrà pieno accesso ai documenti di magazzino ma non a quelli della contabilità). 
Consiglio: io direi comunque di impostare il permesso di scrittura solo a noi stessi, quello di lettura a tutti (tranne ad eventuali file che non vogliamo pubblicare o che abbiamo pubblicato per fare delle nostre prove) e il permesso di esecuzione ad eventuali file CGI che ci servono ad esempio per spedire moduli e-mail ed altre cose.
Il tasto EXECUTE infine consente di eseguire il file come se si facesse doppio click da Esplora Risorse. Quindi un programma eseguibile verrà eseguito ed un file associato ad un programma verrà aperto con tale programma. 

Aprire i files in un programma preimpostato
Se poi vogliamo che i files vengano aperti anche con un programma particolare, bisogna prima di tutto impostare di che programma si tratta.
Per fare tale impostazione andare sul menu: File->Preferences->General->Custum Execute e alla PATH TO PROGRAM inserire il percorso del programma che vogliamo venga lanciato (ad esempio un browser o un programma di gestione immagini), mentre alla voce ITEM TITLE inseriremo il nome del programma come vogliamo che appaia sul menu. Dopo aver confermato con OK, sul menu contestuale dei files, apparirà una nuova voce con il nome ed il comando da noi impostati. 

Altre impostazioni
Sempre tramite il menu File->Preferences->Actions possiamo anche impostare l'azione da eseguire al doppio click del mouse e premendo il tasto INVIO; le possibilità sono: TRANSFER trasferisce il file, VIEW lo visualizza, EXECUTE lo esegue e NOTHING non esegue nessuna azione. 
Purtroppo manca la possibilità di rinominare un file.

Nota sull'uso di maiuscole/minuscole nei nomi di files

Attenzione: Molti server internet fanno distinzione tra minuscole e maiuscole nei nomi di files (quindi considerano i nomi: index.htm, Index.htm e INDEX.HTM come appartenenti a 3 files diversi). Perciò sarebbe opportuno prestare particolare attenzione ai nomi che si danno ai files e a quelli che si utilizzano per richiamarli (tramite link e richiami ad immagini o altri elementi).
Non sarebbe male utilizzare solo lettere minuscole in modo da evitare problemi. A tale scopo è stato ideata dai programmatori di 1st Page un'opzione interessante che si trova sul menu (questa volta di 1st Page): Options->General Program Preferences->Side File Explorer->Force lowercase filenames when inserting links che, se attivata, dovrebbe convertire in sole lettere minuscole il nome e percorso dei file inserito tramite il Side File Explorer. Tale opzione dovrebbe funzionare solo per quanto riguarda i link inseriti tramite trascinamento dalla lista laterale dei files, ma sembrerebbe non funzionare.

Nella versione 3 del programma sono previste le seguenti migliorie (traduco direttamente dal sito): 

· Convertitore SSI 

· Server Web Mini 

· Creazione di Mappe Immagini 

· Trova/Sostituisci Globale (su più files) 

· Strumenti di conversione immagini 

· Possibilità di suddividere lo schermo fra Anteprima di Internet Explorer e Gecko (anteprima interna) 

· Chat IRC interna 

· Wizard di creazione script DHTML fra i più potenti (ti consente di creare menu a tendina, popup e barre in stile outlook) 

· Caricamento più veloce dell'80% e utilizzo di risorse diminuito del 50% 

· Corretto il bug relativo all'a capo automatico 

· HTML Tidy adesso salva le preferenze 

· Adesso puoi aprire più files attraverso la finestra di dialogo o il File Explorer 

· Dozzine di aggiunte 

· .. e altro 

N.B.: Sul sito dicono che l'uscita è prevista per Aprile/Maggio 2001, ma siamo già a fine maggio e ancora non ci sono novità... 
































































































































